summaryrefslogtreecommitdiff
path: root/dev-python/awxkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-01 04:46:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-01 04:46:33 +0100
commit057c56fbd3f54a8b2af3034c585e8df753b10664 (patch)
treee32477af1ebc101c89473674894e1692ae58bc99 /dev-python/awxkit
parent5762cca1020406c58f6b2f0dfbfbad459061ed44 (diff)
gentoo auto-resync : 01:08:2023 - 04:46:33
Diffstat (limited to 'dev-python/awxkit')
-rw-r--r--dev-python/awxkit/Manifest2
-rw-r--r--dev-python/awxkit/awxkit-22.6.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/awxkit/Manifest b/dev-python/awxkit/Manifest
index 28731a7ec851..bd0c4e686ad6 100644
--- a/dev-python/awxkit/Manifest
+++ b/dev-python/awxkit/Manifest
@@ -1,3 +1,5 @@
DIST awx-22.5.0.gh.tar.gz 17629249 BLAKE2B 28e560b36fc16173e8b1e0e2dfbab7a30082e2d3cde40c63a557a30772fce5a03657e57b1cb1de13bf358731d31caee670424ed264ae3ef6aeaff01120fef7a1 SHA512 630c94e747e21e55f32c2f96704ced8ac0214c3869149ad726ac2d4386d3ef7643990b4c07d23201c9191b97bce25b81330581184e040bce6efa341163f74ef7
+DIST awx-22.6.0.gh.tar.gz 17639868 BLAKE2B 8733d1d81c099a56873bea0f38cafe696c70ae4f9274bee644b82b414317cdc537e22a1beea74d566e07cef4e5f5d3adea66a715f43dc30faab35cea1ee4616f SHA512 05fbe7dcc84902eadb40d8a55cc4022aaeedd015534a4caa379cd68684f96422674677c724e8473b0133f9986ae46a7a4a06649a60c8701bd202bc7d684ec972
EBUILD awxkit-22.5.0.ebuild 1115 BLAKE2B 06875923a355fd67ca89751f59a0de48b508d8b00ebf8c06eb5962baca7c30263b2d7b4e24fec3c34462b6fdd478b34d5c333a56dc2f98c67aa47ccdc8304dbc SHA512 534cfedbaff49df3d506b8d00a7b9153a27dd93d7430dac8effb572c59655cd513692d72f435b2dc9bba1a459afdcb7c30d4c1d6ccf6daf2ae52be288b7c17e7
+EBUILD awxkit-22.6.0.ebuild 1115 BLAKE2B 06875923a355fd67ca89751f59a0de48b508d8b00ebf8c06eb5962baca7c30263b2d7b4e24fec3c34462b6fdd478b34d5c333a56dc2f98c67aa47ccdc8304dbc SHA512 534cfedbaff49df3d506b8d00a7b9153a27dd93d7430dac8effb572c59655cd513692d72f435b2dc9bba1a459afdcb7c30d4c1d6ccf6daf2ae52be288b7c17e7
MISC metadata.xml 512 BLAKE2B be7f98bdaff6b814e03c9f6c816a0f1f59dc2e8763298f8a48107ea50b0534eddb314bb6d8b8a0f8c1d7c89c381916031544eea4a06068fb9acab4d2c8c48a57 SHA512 7322d992e1d67ea200df0cbf144d08fd387d7cd6ccb72191fc94dd605c9aeecb4b8083917760e2203296d5514fccd7ca621133aef6622658d1ef2c33171c8b7d
diff --git a/dev-python/awxkit/awxkit-22.6.0.ebuild b/dev-python/awxkit/awxkit-22.6.0.ebuild
new file mode 100644
index 000000000000..52670ed68dde
--- /dev/null
+++ b/dev-python/awxkit/awxkit-22.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+MY_P=awx-${PV}
+DESCRIPTION="Command line interface for Ansible AWX"
+HOMEPAGE="
+ https://github.com/ansible/awx/
+ https://pypi.org/project/awxkit/
+"
+# no sdist, as of 22.0.0
+SRC_URI="
+ https://github.com/ansible/awx/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/awxkit"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ printf '%s\n' "${PV}" > VERSION || die
+
+ sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
+ -e "/'clean'/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}