summaryrefslogtreecommitdiff
path: root/dev-python/backports-csv/backports-csv-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/backports-csv/backports-csv-1.0.7.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/backports-csv/backports-csv-1.0.7.ebuild')
-rw-r--r--dev-python/backports-csv/backports-csv-1.0.7.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/backports-csv/backports-csv-1.0.7.ebuild b/dev-python/backports-csv/backports-csv-1.0.7.ebuild
deleted file mode 100644
index d9cce4776ba6..000000000000
--- a/dev-python/backports-csv/backports-csv-1.0.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Backport of Python 3's 'csv' module"
-HOMEPAGE="https://github.com/ryanhiebert/backports.csv https://pypi.org/project/backports.csv/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- "${EPYTHON}" tests.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}