summaryrefslogtreecommitdiff
path: root/dev-python/backports-lzma/backports-lzma-0.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/backports-lzma/backports-lzma-0.0.10.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/backports-lzma/backports-lzma-0.0.10.ebuild')
-rw-r--r--dev-python/backports-lzma/backports-lzma-0.0.10.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/backports-lzma/backports-lzma-0.0.10.ebuild b/dev-python/backports-lzma/backports-lzma-0.0.10.ebuild
deleted file mode 100644
index 6ce2705754b4..000000000000
--- a/dev-python/backports-lzma/backports-lzma-0.0.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Backport of Python 3.3's lzma module for XZ/LZMA compressed files"
-HOMEPAGE="https://github.com/peterjc/backports.lzma/ https://pypi.org/project/backports.lzma/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-
-RDEPEND="app-arch/xz-utils:0=
- dev-python/backports[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( app-arch/xz-utils:0[extra-filters(+)] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- "${EPYTHON}" test/test_lzma.py || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
- # main namespace provided by dev-python/backports
- rm "${BUILD_DIR}"/lib/backports/__init__.py || die
- rm -f backports/__init__.py || die
-
- distutils-r1_python_install
-}