summaryrefslogtreecommitdiff
path: root/dev-python/bandit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
commit5264c18a325553759d67fb4e059db03cf3fc5c81 (patch)
tree588a7d54829b20df6c11016213dad5808b5c706a /dev-python/bandit
parent27b3683509c5229cce540418778a8b64afbc0009 (diff)
gentoo auto-resync : 18:02:2025 - 00:14:44
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest2
-rw-r--r--dev-python/bandit/bandit-1.8.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index cfdd1cb0675d..18322fa9290c 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,3 +1,5 @@
DIST bandit-1.8.2.tar.gz 4228832 BLAKE2B 71539701adee94e12c168aed5ec51a5772e6e7f91440e41e51a998ac1665a42a5a4d7e9b155f4411e3723efd7a46a44283c0f58569c78c3c090faf26561eb902 SHA512 b4202d208cc05186e80a36c704156827400c79510a9e1ac640b3bdb9926dd57f772e635755ed399b892f559171f5340207f8ea1af92ee2374d7a27c1234e2e70
+DIST bandit-1.8.3.tar.gz 4232005 BLAKE2B 3cfed934d59ac4614b0bfd50348983fa48a8a0346b5c06e0497e5ab5e0807c79e41b046b74880d5e26feba19029b10764d90d9cc8462b561ff04e8f5fd7f7b51 SHA512 50f2ee3f39c2991f030790674e7d25337dac9a4cd0d83d2b76e3152fc3833fb9d8228c347347d3558795b50c2973b825b9e8ab9546ccf6fec60f4f5fbd8ededc
EBUILD bandit-1.8.2.ebuild 1179 BLAKE2B 04c4b2043d2e3354f7fc9a88896d4e627819fbe0ae7f32ed8326a4b9dc261bc4a4aa3d52ee1058a5fa9f060e8f88793c7d77717c9dd7f40629d7aa2c7752c275 SHA512 0cee6288d90158058371617800ea8261cedcca793137f8ab66d7840477075301db94bb9b9256c245d726e37ea21ce27a9bfd7ba42f2eb82f84e0cf41b5d7a54c
+EBUILD bandit-1.8.3.ebuild 1182 BLAKE2B d3650b2bd1075eea26dd58aaa553ed72286ce21ac64929dc03b87bb8643c0de4e219fe98c9959c06cd406b9fa141a17af5cef3a11c108861dfd78f4b5963a7e4 SHA512 d86d0d5e3aa1877e00f287b701f4a9262380dea5a5f75ab684f6b52e13ba4cf0d8bf5623a3375841ef8aac083c50b6a2706ade7087d3a935ed77c37adf98fe9a
MISC metadata.xml 810 BLAKE2B 6f836d0afbb33f233618f056a9d4161cbdafe93abbed2f321e4e799bb75a86e2c4cc27cd43e74d05e1a15496ecf52e6a575ecd8dd4ae463ee37f742331b0086d SHA512 e3dc0280839cb1a54a2585fd6fe19fce66ceff73a7e010479e99e9631c224851b303d577b5de0ba62bc94b78b9b75b30c0103421441bba9753e4231bc3914481
diff --git a/dev-python/bandit/bandit-1.8.3.ebuild b/dev-python/bandit/bandit-1.8.3.ebuild
new file mode 100644
index 000000000000..206df6bf30b1
--- /dev/null
+++ b/dev-python/bandit/bandit-1.8.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/gitpython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest