summaryrefslogtreecommitdiff
path: root/dev-python/beagle/beagle-0.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 20:49:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 20:49:18 +0000
commitc5ee568457ac776b65b71fa444e0dd47535bc44a (patch)
tree1aa40f593e598d7c8352c1d99a30ff9315e690af /dev-python/beagle/beagle-0.3.0-r1.ebuild
parent8eccda982236f2cfe9188bdcaffd9168134f39a9 (diff)
gentoo auto-resync : 27:01:2023 - 20:49:18
Diffstat (limited to 'dev-python/beagle/beagle-0.3.0-r1.ebuild')
-rw-r--r--dev-python/beagle/beagle-0.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/beagle/beagle-0.3.0-r1.ebuild b/dev-python/beagle/beagle-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..70e5f9a5d206
--- /dev/null
+++ b/dev-python/beagle/beagle-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Hound, the code search tool"
+HOMEPAGE="https://beagle-hound.readthedocs.io/en/latest/
+ https://github.com/beaglecli/beagle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# setuptools is needed as rdepend, https://github.com/beaglecli/beagle/pull/14
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"