summaryrefslogtreecommitdiff
path: root/dev-python/bert/bert-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/bert/bert-2.2.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/bert/bert-2.2.0.ebuild')
-rw-r--r--dev-python/bert/bert-2.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/bert/bert-2.2.0.ebuild b/dev-python/bert/bert-2.2.0.ebuild
new file mode 100644
index 000000000000..163daf03d317
--- /dev/null
+++ b/dev-python/bert/bert-2.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="BERT Serialization Library"
+HOMEPAGE="https://pypi.org/project/bert/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/basho-erlastic[${PYTHON_USEDEP}]"
+
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-remove-basestring-fix.patch" )