summaryrefslogtreecommitdiff
path: root/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
commitf66a06e8f9736ea679bc3e95d8c8e90ff7c3f466 (patch)
tree6e12e70b54f33f9219df2139130612649af4161d /dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
parent92a9a3adda432ad2b7af58e08f5493ed6dc81196 (diff)
gentoo auto-resync : 22:09:2023 - 17:17:39
Diffstat (limited to 'dev-python/bibtexparser/bibtexparser-1.4.1.ebuild')
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
new file mode 100644
index 000000000000..178521806dfa
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest