summaryrefslogtreecommitdiff
path: root/dev-python/bitstring/bitstring-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 21:49:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 21:49:58 +0100
commitce80202cfcf7f0dcb80e055eba3f6475232a5961 (patch)
treecbcbc1415a53efca01b7bc3daab62ea7fde9d047 /dev-python/bitstring/bitstring-4.1.1.ebuild
parent41ba6a36cf63678ca63fdd9788e84e3e032dc4ba (diff)
gentoo auto-resync : 23:08:2023 - 21:49:58
Diffstat (limited to 'dev-python/bitstring/bitstring-4.1.1.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-4.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/bitstring/bitstring-4.1.1.ebuild b/dev-python/bitstring/bitstring-4.1.1.ebuild
new file mode 100644
index 000000000000..ed11001fdc22
--- /dev/null
+++ b/dev-python/bitstring/bitstring-4.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="
+ https://github.com/scott-griffiths/bitstring/
+ https://pypi.org/project/bitstring/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/bitarray-3[${PYTHON_USEDEP}]
+ >=dev-python/bitarray-2.8.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest