summaryrefslogtreecommitdiff
path: root/dev-python/black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-09 04:26:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-09 04:26:33 +0100
commit6ee17dd82a3bcd0e90af4ebfbb3e411d342761be (patch)
tree5ade54018efa76614b79d832bbe15a22021b6d8c /dev-python/black
parent325837835fc86686829aaa6acace3d3c06c74cea (diff)
gentoo auto-resync : 09:10:2024 - 04:26:32
Diffstat (limited to 'dev-python/black')
-rw-r--r--dev-python/black/Manifest2
-rw-r--r--dev-python/black/black-24.10.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 86303eb5a720..4ffb381320da 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,5 +1,7 @@
+DIST black-24.10.0.tar.gz 645813 BLAKE2B ba53b3d38d982c81d66291318ba6ab7df75779207fea77af3a4554cebaa23061d9d22f97613faa38b869694edcf56ae0001ff27eb34fba1e1bc8732dbf0a0796 SHA512 36285528b2a3ca9b68b806cf43cf04061f80e0ad5e693c70d2dc254b59d15f41ec5c2a4328d4cda42abe005def2d86d8fc501c1649b223a225c8bddddf82589a
DIST black-24.4.2.tar.gz 642299 BLAKE2B aa62394dc4a14fd6dd49502a86e46e7f707d6342127e2fb3b5cb7365ab392f5a0514df548d30219e9b6ed1f9d8ca80241ea206a06011ef8dc3d770191d3328ce SHA512 f3fb63fdbff947a217ad371939a6eaac1e818f58fb924516639f3c9469f0db6fbda8d4b207163d4a6db8a58a048fefe46fbfdb1ddf40f91348bd767208e60f35
DIST black-24.8.0.tar.gz 644810 BLAKE2B 8961bca9caf4db7178b3bdc4cccbf8bea667329cb2a13e388fa966b0cc9c059edf6ee17f281b72b9b8b66359781d525cc3983b2cb7a5e0638418d9454e51b188 SHA512 2ba2579964764032d30378232f5874a5d71981eb76706ed12004c08c78eaa56bfb8e0740e513280b9246f54082443c64aa31d31955fdccae9c6e6ba96f54e1cc
+EBUILD black-24.10.0.ebuild 1348 BLAKE2B b73cc3cfe4aa4845dc8926d305ba8c5656bdc32c7af954ecc69952b440a83c3ff58c9842d10aa0bf1dd6d4601080faa4d1494894acdb56022181944f54c8ab87 SHA512 710fe3a5e8c51bd062b20f083f9246567864705a361a5cc7d6e76564aeca53d66fb1d14c296ed4c3e5606d08fb5a8647a76c2ceb93ad94580dbf43afa878fa90
EBUILD black-24.4.2-r1.ebuild 1341 BLAKE2B 36b032ffded7ce49974c22438c1315121643d86d092c78efce0d089d26ba82876dfc43cfd831d14a9dd5b889294103b716f6e2a62775f7cfd0905c1badb39d00 SHA512 fcf177a810e93854f4229d8f4bd3242ba7dcfc31e6f1ac186a0a48cec1745433cd835440fcab75f3dec47f393e55ab2ecf207b837afe2cf6612350a51eba0246
EBUILD black-24.8.0.ebuild 1342 BLAKE2B f64a740964e77ec006bac6e8250e61d315f4bdafa40db89f5c12cc348989f71761c7769b98913e65666612bfe5991dc5bbfa7832faeca547ccc6967855c338de SHA512 e504b01e3826b2c7294e45b536a01a11b3927ae7b4b256e7de6f8ccb22aeedd54e8d1084d457677505b2b31f6dca3e7c77d45d9d6537bfca634a15f80ad8ebf0
MISC metadata.xml 446 BLAKE2B 7d9bdbc4fdd62c1b4278a824a75dede64ccd3a4d865722a99edbd4e316342879eefa7b249c453668a5d33009e134e2feb4d1ac01976146c3e988f3724749d4a4 SHA512 0a3a912fc1d439a92452e48c9749705cd2307e645bb1274d22265656f6101574edda79cf04c03ae512818e7077e404f79fb1f70fd68d9c7cd3be3417f991700d
diff --git a/dev-python/black/black-24.10.0.ebuild b/dev-python/black/black-24.10.0.ebuild
new file mode 100644
index 000000000000..29e176c82187
--- /dev/null
+++ b/dev-python/black/black-24.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.10[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}