summaryrefslogtreecommitdiff
path: root/dev-python/bleach
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/bleach
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest3
-rw-r--r--dev-python/bleach/bleach-3.1.5.ebuild38
-rw-r--r--dev-python/bleach/files/bleach-3.1.5-py39.patch36
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 45ce93e68dad..cc25bf4fa8e6 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1,3 +1,6 @@
+AUX bleach-3.1.5-py39.patch 1043 BLAKE2B 9af8ba9c8e05eecc96ba6e85424e748cbc8c36ff251144fc32b78987f3c1b902fa725c05aa0d750184cd4ca98ee0a3f577020d7351cb0869949cbe038f819444 SHA512 c1b9b81b3a2c79a468aed858d75be143d441a10ceea5ea95f131e9e84502633a7c35dfead709fffce1c137093200123bbdcaec4d71180f747d839cb945e98afa
DIST bleach-3.1.4.tar.gz 177813 BLAKE2B 446740fcb7f2aa137d7353b0fbbebd57db9d571248b67f4d0a6a47baf3581aa3793431f68cf340bc8a0478d21e84aafca17538d069d74657285fdc4a06869586 SHA512 da233794954aad4e63e334d3c3bab9089e7767e0d784b8c51d12d2862ac6ed73ad5122b4d9cfd291ba7d9fc86a4a3b515429d7e383f241a46e3290acefa2ffc6
+DIST bleach-3.1.5.tar.gz 177972 BLAKE2B 6033871f757247f05ee67f66b3596c7a76a9bc5105113206bc8749f9ed103fb6a7c91630540f5f17ddc17e261b24043cc2edcc2562ea7f4cf54774080854de32 SHA512 20db9ab6924a1e884107f30e1059f774b45fd169d3965a61a4ff028e3de17e30be81474d7da89d9275b2173a005c5504a9d11f0e0ca528bf36a9bf08aeed0607
EBUILD bleach-3.1.4-r1.ebuild 867 BLAKE2B 4ee516e3b87a244dd4e065ab8ebc75e17ce257ec5d32826add063b5f71ac53409a63c3d2be2a1b4459087250dcd9be96768fc1254a1735f7ddca0619f411347d SHA512 be209bccb8f10374c9090042f030177176684e9cde540a18c30976405ebbb59a7a4e5fff7a2dfc45c6fa02c559ce8a3b5626a7f9e95b04892e8c22a07d873d0f
+EBUILD bleach-3.1.5.ebuild 959 BLAKE2B 8368842a064f8f783ae464dcfa75ea555e799c0c7cc54dd2e341d4304327c389dcf684334bb3bc06efcd6edda44969adcdc3111b76e9a476ad417020e0bd6986 SHA512 804bcad8b8f390120a7db8f40fe269a842fc68ac7242eb6f298256689cd2aae67d635d2a93606490d14db847fa87efa973256734db90f1c25221ac0ddeb917e5
MISC metadata.xml 375 BLAKE2B eb46fe64fd2800b8222ce88a2ef34be12f68a5a014417ebbfcf3466beda9c64f6a6d1ef4431d83b4948c1513de81840d1f5c65961d851213f928fcc6a66045e5 SHA512 9f8329e1fe0a9a7a6268dee15c098bdd7893da00a3c4f4dcab207586dccc5f6b471754be0eacb21fbd7fcce5e3130a631fbf1fe60a27ea525552d7ef2d9c173a
diff --git a/dev-python/bleach/bleach-3.1.5.ebuild b/dev-python/bleach/bleach-3.1.5.ebuild
new file mode 100644
index 000000000000..db2a844f98ff
--- /dev/null
+++ b/dev-python/bleach/bleach-3.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py tests/test_clean.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/bleach/files/bleach-3.1.5-py39.patch b/dev-python/bleach/files/bleach-3.1.5-py39.patch
new file mode 100644
index 000000000000..ce1296236b6d
--- /dev/null
+++ b/dev-python/bleach/files/bleach-3.1.5-py39.patch
@@ -0,0 +1,36 @@
+diff --git a/tests/test_clean.py b/tests/test_clean.py
+index 133cd82..4dcb9f4 100644
+--- a/tests/test_clean.py
++++ b/tests/test_clean.py
+@@ -597,31 +597,16 @@ def test_attributes_list():
+ {'protocols': ['http']},
+ '<a href="example.com">valid</a>'
+ ),
+- (
+- '<a href="example.com:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="example.com:8000">valid</a>'
+- ),
+ (
+ '<a href="localhost">valid</a>',
+ {'protocols': ['http']},
+ '<a href="localhost">valid</a>'
+ ),
+- (
+- '<a href="localhost:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="localhost:8000">valid</a>'
+- ),
+ (
+ '<a href="192.168.100.100">valid</a>',
+ {'protocols': ['http']},
+ '<a href="192.168.100.100">valid</a>'
+ ),
+- (
+- '<a href="192.168.100.100:8000">valid</a>',
+- {'protocols': ['http']},
+- '<a href="192.168.100.100:8000">valid</a>'
+- ),
+
+ # Disallow implicit http if disallowed
+ (