summaryrefslogtreecommitdiff
path: root/dev-python/blinker/blinker-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
commit4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (patch)
treec7557ae36b9b2bfa7134849511e79da938581c5f /dev-python/blinker/blinker-1.8.1.ebuild
parent5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (diff)
gentoo auto-resync : 30:04:2024 - 00:00:01
Diffstat (limited to 'dev-python/blinker/blinker-1.8.1.ebuild')
-rw-r--r--dev-python/blinker/blinker-1.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/blinker/blinker-1.8.1.ebuild b/dev-python/blinker/blinker-1.8.1.ebuild
new file mode 100644
index 000000000000..9df417e40e36
--- /dev/null
+++ b/dev-python/blinker/blinker-1.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="
+ https://github.com/pallets-eco/blinker/
+ https://pypi.org/project/blinker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}