summaryrefslogtreecommitdiff
path: root/dev-python/boltons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/boltons
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/boltons')
-rw-r--r--dev-python/boltons/Manifest5
-rw-r--r--dev-python/boltons/boltons-21.0.0-r1.ebuild37
-rw-r--r--dev-python/boltons/boltons-21.0.0.ebuild30
-rw-r--r--dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch7
4 files changed, 47 insertions, 32 deletions
diff --git a/dev-python/boltons/Manifest b/dev-python/boltons/Manifest
index a71ce6d86bd9..823fec368c34 100644
--- a/dev-python/boltons/Manifest
+++ b/dev-python/boltons/Manifest
@@ -1,4 +1,5 @@
AUX boltons-21.0.0-python3.10.patch 3393 BLAKE2B 24d9bf2368a0716332e85222fcf8965b9633aa26967e9f9bac6f5ee31fbd8aa71dc2e24bfeeaa6ad766511f8f09a68a1b4288fa66b9ab7ec58f1e01453d5adae SHA512 3db60c0a2cd8680fc58151ad788838b6d795c16b5162326382aba883a7fe86a294cc1d490d40ff40ecd3eecb37e518c85bee0c67910938e8d3623f0dc5f6d6df
-DIST boltons-21.0.0.tar.gz 241010 BLAKE2B e8c7cba3aadc40fbf40b784c8060d7b4f9d89457a4416c8fe9c733c3a35cf292609b2cc4e43e20a1308add6b854c3e00cb55274328a14699b3c704b73c189318 SHA512 5f5d642ab8ce0bc26133f4bd5059071bc86ca8e6619ebac796d522a0e4c39b958176ccc9de9a56e0448b24bdcf569e73f51011d5a9fc875bdef12a363f106018
-EBUILD boltons-21.0.0.ebuild 707 BLAKE2B 06bc8e418eb9ab524ad7e8be140d3eae33890dadccece13a2e0bf8da4bd50a6ae1ac98f72f35242e35cdc03e7e1e80ee83a9d36523ee8587bb9fa142b5e6bc9d SHA512 28d8eef858a1614a41ec7858cc25e1cbc10147c7e721e4d21081179f42a8ed44a07d19729613f8504d193aba845dd7b3c82481a51815066d77b8f5a142ecb0da
+AUX boltons-21.0.0-python3.11-tests.patch 267 BLAKE2B 03af16f7f058094369f97aa4753833cfd43a0f0da7dbb6a423b3e4fb8b4f52692d993f22449232d8653075f1031d07a25d4a3a7f8d71268d62ba8a62562a1b81 SHA512 de99f35ed56c50122b531a9750225d5135d1b429fdb4a8312d04e4c1cb9cfffeaeec08fa718223d3e1952656f40dfb0698f40c855d09e9db63832c5be0ddcc04
+DIST boltons-21.0.0.gh.tar.gz 241010 BLAKE2B e8c7cba3aadc40fbf40b784c8060d7b4f9d89457a4416c8fe9c733c3a35cf292609b2cc4e43e20a1308add6b854c3e00cb55274328a14699b3c704b73c189318 SHA512 5f5d642ab8ce0bc26133f4bd5059071bc86ca8e6619ebac796d522a0e4c39b958176ccc9de9a56e0448b24bdcf569e73f51011d5a9fc875bdef12a363f106018
+EBUILD boltons-21.0.0-r1.ebuild 941 BLAKE2B dd8a96c2d2d1950613cd36b652597a0c74547ac9c73998deb4ceb31600c8351f39647025dd2b1e99b7623cd981014d491ccaed31ef6061d1acb31ba71674e575 SHA512 c65ebb94aa1a947f62a5d498ee96dd54371c8108d7b739c35a30ff65d1bbbe09d3c818371c268f7bfc8f999b9d7c6545af3098c7ec11bf470abfe437ae372f19
MISC metadata.xml 395 BLAKE2B 6ed304f1dced75dfd795b9fe582ec669bf1c8ba5fefeb9e753b11aa20de8fc0966fc9a8a0ed40e460dd23a67ef0e5721a8dae27b3d799a4be629537bb18f54c9 SHA512 fb73041a95df230153dc686e21a88d91bb06367ae8c22a20777c4a0f13202cbaf59396f4ed2630265d331d6461a6da85f57ba62cc432c4d9105b8404753b383b
diff --git a/dev-python/boltons/boltons-21.0.0-r1.ebuild b/dev-python/boltons/boltons-21.0.0-r1.ebuild
new file mode 100644
index 000000000000..6ec093c9fd19
--- /dev/null
+++ b/dev-python/boltons/boltons-21.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-python utilities in the same spirit as the standard library"
+HOMEPAGE="https://boltons.readthedocs.io/"
+SRC_URI="https://github.com/mahmoud/boltons/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+DOCS=( CHANGELOG.md README.md TODO.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.10.patch
+ "${FILESDIR}"/${P}-python3.11-tests.patch
+)
+
+EPYTEST_DESELECT=(
+ # fails if there's any noise/differences in traceback text caused
+ # by e.g. pytest-qt noise or python3.11 adding ^^^^^^ markers
+ tests/test_tbutils.py::test_exception_info
+)
+
+python_test() {
+ epytest -p no:django
+}
diff --git a/dev-python/boltons/boltons-21.0.0.ebuild b/dev-python/boltons/boltons-21.0.0.ebuild
deleted file mode 100644
index 27fea4ce8935..000000000000
--- a/dev-python/boltons/boltons-21.0.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Pure-python utilities in the same spirit as the standard library"
-HOMEPAGE="https://boltons.readthedocs.org/"
-SRC_URI="https://github.com/mahmoud/boltons/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-
-DOCS=( CHANGELOG.md README.md TODO.rst )
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.10.patch
-)
-
-python_test() {
- # failure in test_exception_info with pytest-qt
- epytest -p no:pytest-qt
-}
diff --git a/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch b/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch
new file mode 100644
index 000000000000..a54b2a4d0cf1
--- /dev/null
+++ b/dev-python/boltons/files/boltons-21.0.0-python3.11-tests.patch
@@ -0,0 +1,7 @@
+object.__getstate__ was added in 3.11 (bpo-26579) and the test is unaware
+--- a/tests/test_dictutils.py
++++ b/tests/test_dictutils.py
+@@ -476,2 +476,3 @@
+ '__getitem__',
++ '__getstate__',
+ '__gt__',