summaryrefslogtreecommitdiff
path: root/dev-python/booleanOperations/booleanOperations-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/booleanOperations/booleanOperations-0.8.0.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/booleanOperations/booleanOperations-0.8.0.ebuild')
-rw-r--r--dev-python/booleanOperations/booleanOperations-0.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/booleanOperations/booleanOperations-0.8.0.ebuild b/dev-python/booleanOperations/booleanOperations-0.8.0.ebuild
new file mode 100644
index 000000000000..3a04ff471681
--- /dev/null
+++ b/dev-python/booleanOperations/booleanOperations-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Boolean operations on paths"
+HOMEPAGE="https://github.com/typemytype/booleanOperations"
+SRC_URI="https://github.com/typemytype/booleanOperations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/pyclipper[${PYTHON_USEDEP}]
+ dev-python/ufoLib[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}