summaryrefslogtreecommitdiff
path: root/dev-python/boto3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-python/boto3
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.28.54.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8ac6578051f8..3a0cb559d6a7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,6 +1,8 @@
DIST boto3-1.28.49.gh.tar.gz 700443 BLAKE2B 7c76e0ee6d6de1f7a67534a49e54092a564d419f9fc18b25375d2416af07987039bf864e0c2a996d5b64c3f9207dcd50da6ee5b0e2bf606e453d7841ddd6f7d4 SHA512 597debebb60c33bdf2bcc485bbf9ab7c433a5750b71708ffcd2847b6b21199c1c598edeb35e236f6b7feca3f762b5d62f9637e00876b7c0629baae50e7f132c9
DIST boto3-1.28.53.gh.tar.gz 702652 BLAKE2B 6a64fa2c018000a6b89f47a49eaf0270a2f694f02720c0e0527b5ce671bf3ad195f40fa592829bbe9a3b30ede56fd335a81bb30f862bfc6992883dd86d6b9a75 SHA512 750d4905625b207d05842950349eeadaef9bbb413adfc8096998292edeec8985c5488c565f3b5b6f5a00354e69f3071ad1491428b1f894be2b40b23db767be36
+DIST boto3-1.28.54.gh.tar.gz 703165 BLAKE2B f18666ece9f7b722915fb082c6e45280dedac4dc10e89d453c895515af623ea9658195e3e65bb17a9cfcd637a711e5f323c0d8dbd5fe00c16b7c560ef303a8e1 SHA512 e6d5a06aff033badf5fd3cc37a7324731fc15aeea7d5257223e46473958dfcbda96b67279e2c22354f705b5538a100c852a0561af2cb429a321245dc5d814e99
EBUILD boto3-1.28.49.ebuild 1581 BLAKE2B 0bd744caa1591cf114c8ce87e14d9af4afd13782c7e012c6701b9a13b66d913798bffa5a79753d1bd9c5928893c6b92478d9d3c8a764d59982bc864bcbd0619f SHA512 e3985f59bcdc4548dc51ca23290b3ac4d9d0b5e6f214e3e7a73dde99232ba7fde47983aa8fdd6679d148f4ab56c0b01906e431c33c3f9b8eebc7cb75f99b74dc
EBUILD boto3-1.28.53.ebuild 1588 BLAKE2B 7868e2dbbe0ec485326e70c75cd785d0d369de83650d28b6501faaa4d21a8c1952c68c1e06659d1c4f70baf420b70edfb714e82d60dc9dfac2f494cc42066317 SHA512 a16a292694a5fd614ab03939fa6131614b287c8e475a83f40f463f0051f6404aa85413713038de60089b6489fc5fa9688bedd1d66ce578ed3fb0cd1b3c237d72
+EBUILD boto3-1.28.54.ebuild 1588 BLAKE2B 7868e2dbbe0ec485326e70c75cd785d0d369de83650d28b6501faaa4d21a8c1952c68c1e06659d1c4f70baf420b70edfb714e82d60dc9dfac2f494cc42066317 SHA512 a16a292694a5fd614ab03939fa6131614b287c8e475a83f40f463f0051f6404aa85413713038de60089b6489fc5fa9688bedd1d66ce578ed3fb0cd1b3c237d72
EBUILD boto3-9999.ebuild 1532 BLAKE2B d9c16eb4938ac7488765eca7dc3d5d55402c5aeed4b4e380c9d0433a4e18a94cd11938b43fbe3584b95bc36fec90557a1cfb6017a41fa70807bc06b941e3eca6 SHA512 2d6bd178dd4b7b9b30ed092f69ffdf01e4450eae8e5ee86bd5dcced4370f6f49a440067ae598e126d7ca0f50f9c1212e734ccbd5073fb4fcdef8850327b57763
MISC metadata.xml 493 BLAKE2B 7d6324fc877ffe1d20c5369c2af0b09a7028f94d28f1841188913d0d8be7ea699c9d3f92c624992c4c96bd69615d3a1211a2483c76c56b7d3082492e43512523 SHA512 44420d8c03d5986f990b76369edfa8dfd7659b4952db3ad946fd05392ec594628a28745ad888d055d4f074d5214f61fcffafe6c04c4ab54109d45ac0371582bd
diff --git a/dev-python/boto3/boto3-1.28.54.ebuild b/dev-python/boto3/boto3-1.28.54.ebuild
new file mode 100644
index 000000000000..90e1b0ce7382
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.54.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}