summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-08 12:29:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-08 12:29:28 +0100
commit8e49340ce0aaf205556648d8fa27dd30e8cf4435 (patch)
tree38cc25a0f12067b6b184788983173496ae9936e6 /dev-python/bottle
parent6c1090c8458fa6e15fd24227293d60bbf356eb60 (diff)
gentoo auto-resync : 08:09:2024 - 12:29:27
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.13.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index 596148b33009..a29dd002642b 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,6 +1,8 @@
AUX bottle-0.12.25-py312.patch 1086 BLAKE2B fb0b854bca7b7671046647c3bd3048053db5500de86bf9bbf11c59ca37a161914804012a6379509bea2bcc4cb82c1c9f5faf97aca95d970297a0e72326605208 SHA512 85c9090dcad1edc8098c451b4dc1afc0f6edb5e7e38cfa3901f50a13ba9066dac338660e1419fd4eb7f0ce6d9ae496c89d7cfa47cb55f7038bd957a581132663
DIST bottle-0.12.25.tar.gz 74231 BLAKE2B 2856d94e1525f21e272d70ca3101188ea65417179342d7b3e971c5d1a3be77265e4197e5d29764a5739adbd984883ed121524f29e6a5933b8681e2c34b511a57 SHA512 14b8ed1ffd58f9667d451872ccf73a6f4bf8f7ffb9329f55314f90c770630cfe3f9956f786bcc7fd5f67fde22d14961952969af405912ebe71f019ca6599c975
DIST bottle-0.13.0.tar.gz 99295 BLAKE2B ad97db9c0d9313d836fc166809205b0b812e1d7ac3de05b5610aada01a19e8c785ccf8254304223fa77606f283d2e4621c5db2c5f36e950756c5ffef0bda4fa9 SHA512 17951d723c960ed045500c3721b0cccb3015c69f9e3cd2813e29984dbc16cffa63b108f18f36e0b3cf32b25bf9d900603f58569e1ab65bf53096c056d6ea6714
+DIST bottle-0.13.1.tar.gz 836422 BLAKE2B 8160de68b04cab8b3fe86dfc4b9f354ff2de523eae79277b91889e634629e9b462f9013c9821409ad3b43aa329c02ddce66bde45bc1c650a2826e641236b2fe7 SHA512 504704d20712723436c61712e8aa41e603a0f66f74927b4d4122aaea3a090ab910d5daa12217d48b803a66fc3d96d491c2a0b30df236aff50520adb8c115609f
EBUILD bottle-0.12.25-r1.ebuild 1356 BLAKE2B 69aadff2903cc50319c8330e1ab4f03067dd3ef4506b9874f6959a39f62aa8df9c6cf31385fd7dbcaeb76aed9996889771c24850ab02272567b204c220c83f9e SHA512 41db5da4a759412e40f30127002520f91710e78ab5700421a6e7918292989127d793deb6140a598e2eac6fbd2c7f7ca36ca7d13f1a22fcee1d7f6fffa2604f8b
EBUILD bottle-0.13.0.ebuild 1086 BLAKE2B 6f04447f7749c11837e9fd7286edb2a9c56cd842df4303ac81ff1d23d8018bdb3d499ade46c0bb13f269991cc102975ff363a944b75226c6d26d5ba2265349dd SHA512 fcb0cead9f7023cddb077b169d98d434d43c4a08e99b2220844a2dc90177d4e13a0c928e9f682ea20756e90ce82acfcc2875cf7ab01d6c2a6d1d43a644dad4ba
+EBUILD bottle-0.13.1.ebuild 998 BLAKE2B b38f18f1e35d52392d8d145b85146bba45b7b31994729ea85e805f186bc8a056f64ad4933c832b594321c76d84fd9146ab8ee245f015a614d59e7dc2cd0233e0 SHA512 0c8633952524012c1a3ee39609525df874395bd2e35ab7add61813fb438e7bf88a2ea0974dc8af01b8df14defb77139dead2ca3381cce0e097fc00529c256ca9
MISC metadata.xml 389 BLAKE2B fa960ae3a5dbead30cd7bc7617f87d5f2597716f6edef3a2af4ab15a7f45cfab6db98d77335a24fd792a6161dde7b7ff183d934e19cf69f7e1b2c72485cafd00 SHA512 06b65bd22b74e1e77597e65872d6ecc471e97848b05c02a0e2d35f98499d4c56164a15093ea96b9e55a59ed2624bed2adfb45d58d4a79c426087ca2ddf89f6b4
diff --git a/dev-python/bottle/bottle-0.13.1.ebuild b/dev-python/bottle/bottle-0.13.1.ebuild
new file mode 100644
index 000000000000..e4376f17d3e4
--- /dev/null
+++ b/dev-python/bottle/bottle-0.13.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}