summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/bottle
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.12.19.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index 628824ffb18e..84f56c4ddbc0 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,4 +1,6 @@
AUX bottle-0.12.8-py3.5-backport.patch 1720 BLAKE2B 63081eee3765d060d7381a0eeca97fde17367273b0308449678301f0d2ed9357c90881aeeff31c6a26920ff256b76b0567a74628499fb4d9f2325bc75de6a2e8 SHA512 10f8b95d77d35db582be9bb937ca0c52050c22faa191f373b34039c6ddec24a8e71ce26f6bc9c3f3af7973670343b2f3131c02ed626e3d161a636f8c9e4cdd2b
DIST bottle-0.12.18.tar.gz 71557 BLAKE2B a34cc1ab9a2a8505b7fda8bbddbae30b4e6c4829cae53f0f886237a21fdfa7f2b2463b216d7a16464539f41bdce4c1dabb5cc66027b8fdd19b10e9a78a3cdbb5 SHA512 db8a341cd80d755205518bb9eac5b79dca9e541ab3ad9d9d57f891d895f7df75a8facd16b068cbdf7c4f884f35e384449f4cbd565a43e9c5d000d3a9f5b7dcb0
+DIST bottle-0.12.19.tar.gz 73142 BLAKE2B e59d7a507d3401869ba4953a48274062fc56226afa2f7aad596b4ef4352e4a79cea2d224dfe32d7ce014e4f4a3ba088d0e7a0886f64a84bb6b78571e953fa3c3 SHA512 e5d2f6a32d1b89ae3cc9607456c0614db2b58882c6d36273d695c51d3d77b1858cac4d914dbf19bca3b74be68c197aa6473f162e40d9b7ae2af3a084a28c2637
EBUILD bottle-0.12.18-r1.ebuild 1386 BLAKE2B f029ada9337b48bc8c446eee4a9119f99fe2e3e11f8d9f850a0da49e6170fbfac111912fb526469b9099bef86d96d5814b0b645ebece21014f90c8f1d5b1af6b SHA512 2e89d8b724dfc229df65f6c6737e2feeba9126bc4fcbc7859978e4110c90d0e66760aa137e9caee308a06fb0facd35169217e8f208914bd247e06a4928170427
+EBUILD bottle-0.12.19.ebuild 1394 BLAKE2B d70d4be4a2dc0e4be191579086b0bcdbe494cef8a82ba5dd575710c099805549c9e893b9e739271a880c7f855084b546238c3d1ada4f9a543d995c51817de4d4 SHA512 1da095b842b375e55211ee0187077b9415c7e4e1fede43e50ac69dae6f35cc550f0de3126162b6593ecb682961059c794a477c7498b37ea4ea797040ceb60edb
MISC metadata.xml 319 BLAKE2B 29a2c856ee0a0af9214a5cec842b697fcb095d2bcf4702225b2e81d4f715967c29a383da78c43ac60d4464e27e651e81f1b085684b0b6f39925a6df7c36a54c4 SHA512 2ff50f032ea6042a32a7d391906ff95d00115367770423874aa6ee638b1db03fc0b7fabc484e1ecc002eff1e5abf5d45075463b76b7d512535d4820c46b56251
diff --git a/dev-python/bottle/bottle-0.12.19.ebuild b/dev-python/bottle/bottle-0.12.19.ebuild
new file mode 100644
index 000000000000..13d52c768417
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.19.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ https://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/mako[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}