summaryrefslogtreecommitdiff
path: root/dev-python/bpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/bpython
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest2
-rw-r--r--dev-python/bpython/bpython-0.19.ebuild32
2 files changed, 11 insertions, 23 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 5c45624e3857..87d431b66920 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,3 +1,3 @@
DIST bpython-0.19.tar.gz 216564 BLAKE2B a0b469ae28965e7926838b2d520aed0199a39ad5d9d5650e34446601e6e5f023a6c09cbdd85a30b2873dc72b5ef5774c483d5f627accaf29dce7e6f8628cc1df SHA512 7c746848671d5de0b63f0284d2af87c12480fa1ae3e89eb10093ab5dfd42f926171f29bd8bcc19fe173fc58f7eff7276da4639d580836f0d112dc5e85000dc55
-EBUILD bpython-0.19.ebuild 1487 BLAKE2B c78099c542f93af4606f439e5c12e1969ec7ccee20a197e40b6c2c6c437873700a65cbdb316f8f47b25ee7adbe98cdac0ebbc7f84e30feae9824e36b4e0f3493 SHA512 c605c91478e64c3c1bf9362d9faafda703211bfe71e37a1d0b5ad79a3f8117e3194f08bf6fb4dcfd7c2310b3f63ea8a3bb96a4e46eeb4042767962fab6409351
+EBUILD bpython-0.19.ebuild 1293 BLAKE2B 78f1b53f228bd067c3c9c8c2af79a6df96d9623f3e531a7334295f2ac54038e4ee2072d3db971bd943b325130e524c949fd116812903a47bdd781a4b4e4bfd66 SHA512 82c75f49d3b0d3edc3f46c0454a1941f13f5690faec16fc9cc76b76fd7afe8f381f7e0aed9ba746ec12dce417b0d4d24658c512aba0e40eec7c9c008f22b80ef
MISC metadata.xml 527 BLAKE2B 2691755a7de852d518e3646b965483a12169e56dbfed6fd43961d6833d9ef673f8c0ab146a2677dcef6cfc173f3a9f2200fbb39ed870570b8f28ca641c617e60 SHA512 0710368b088d3c9bcd52c93df885a730a4a3e189781dcd1a10d63fe6dfaabb486e972150ebb693ed1859a4461aa1343bb5ccc80772406abed4e0f0f9776329be
diff --git a/dev-python/bpython/bpython-0.19.ebuild b/dev-python/bpython/bpython-0.19.ebuild
index 178c7afd56d5..9e264fef8f6c 100644
--- a/dev-python/bpython/bpython-0.19.ebuild
+++ b/dev-python/bpython/bpython-0.19.ebuild
@@ -27,31 +27,19 @@ RDEPEND="
dev-python/urwid[${PYTHON_USEDEP}]
dev-python/watchdog[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
-# Req'd for clean build by each impl
-DISTUTILS_IN_SOURCE_BUILD=1
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest
-RESTRICT="test" #659110
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c doc/sphinx/source/ \
- doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
- fi
-}
-
-python_test() {
- pushd build/lib > /dev/null
- "${PYTHON}" -m unittest discover || die
- popd > /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
- distutils-r1_python_install_all
+src_prepare() {
+ sed -e 's:test_exec_dunder_file:_&:' \
+ -e 's:test_exec_nonascii_file_linenums:_&:' \
+ -i bpython/test/test_args.py || die
+ distutils-r1_src_prepare
}