summaryrefslogtreecommitdiff
path: root/dev-python/bracex/bracex-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
commit15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (patch)
tree6da8c6fe191bb632a2a6454968d2d1cc1338a5dc /dev-python/bracex/bracex-2.4.ebuild
parentec82846d15c127f36a0f0620e30c9c0fbbdd514c (diff)
gentoo auto-resync : 02:09:2023 - 10:15:56
Diffstat (limited to 'dev-python/bracex/bracex-2.4.ebuild')
-rw-r--r--dev-python/bracex/bracex-2.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/bracex/bracex-2.4.ebuild b/dev-python/bracex/bracex-2.4.ebuild
new file mode 100644
index 000000000000..f1de5d961183
--- /dev/null
+++ b/dev-python/bracex/bracex-2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-material
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs-pymdownx-material-extras
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="Bash style brace expansion for Python"
+HOMEPAGE="
+ https://github.com/facelessuser/bracex/
+ https://pypi.org/project/bracex/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}