summaryrefslogtreecommitdiff
path: root/dev-python/bracex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/bracex
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/bracex')
-rw-r--r--dev-python/bracex/Manifest3
-rw-r--r--dev-python/bracex/bracex-2.0.1.ebuild45
-rw-r--r--dev-python/bracex/metadata.xml26
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/bracex/Manifest b/dev-python/bracex/Manifest
new file mode 100644
index 000000000000..b08578e75586
--- /dev/null
+++ b/dev-python/bracex/Manifest
@@ -0,0 +1,3 @@
+DIST bracex-2.0.1.tar.gz 24356 BLAKE2B dc4df37c569e26a4319d4240694a397926075ba8cc3d6f44cb35ae42dd20c36f690f904d6a6895aa4e02d7108b3bc173d4a6f672ac9bf5ee426f280dab5fc0e1 SHA512 28758ce4796ad64cceeab0e93edf4c9bb71c6a968db3b917db3e22619278a4639e587da7070c15c5a3c8c1121871541e7764904769859c3c590ac8611f224a13
+EBUILD bracex-2.0.1.ebuild 1047 BLAKE2B 6e95538bd6fb2c2ef5975dd6de844e52fd792b829d8e3971444a13b8a31a22cacba982220625c6c04a21de88fb81b3fce819689d7e6f4d40ddea893a5bcfe7ba SHA512 16e52304611f7eca1b4ed555b6239fac7ccce63f510a600e3c64cce15bb86735ce2cc37517022d5443b2d0f3fb05340580d43d708862ec0b87d36dc390f6fd5f
+MISC metadata.xml 1198 BLAKE2B 0fd219ffba7d698f8dfc8bfb131e2baad454e2cdea289d8cf0875bdad2cb818d47596af1f47f98c0e1861ef1097e877425fbc15014b5711447747c63511d2e9e SHA512 3ee15cdfed6e6a8cc0304fcac06b1448e413a4d6e7205a1164297f2343cf38672fd3bad03436554e631be757b6026a678bf071af07c86b74dde9ae23df3ae23f
diff --git a/dev-python/bracex/bracex-2.0.1.ebuild b/dev-python/bracex/bracex-2.0.1.ebuild
new file mode 100644
index 000000000000..3219582fd350
--- /dev/null
+++ b/dev-python/bracex/bracex-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-material
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs_pymdownx_material_extras
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Bash style brace expansion for Python"
+HOMEPAGE="
+ https://github.com/facelessuser/bracex
+ https://pypi.org/project/bracex
+"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/bracex/metadata.xml b/dev-python/bracex/metadata.xml
new file mode 100644
index 000000000000..f0d91e4ea335
--- /dev/null
+++ b/dev-python/bracex/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/bracex</remote-id>
+ <remote-id type="pypi">bracex</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Why Bracex over other solutions?
+
+ Bracex actually follows pretty closely to how Bash processes braces. It is not a 1:1 implementation of how Bash handles braces, but generally, it follows very closely. Almost all of the test cases are run through Bash first, then our implementation is compared against the results Bash gives. There are a few cases where we have purposely deviated. For instance, we are not handling Bash's command line inputs, so we are not giving special meaning to back ticks and quotes at this time.
+ </longdescription>
+</pkgmetadata>