summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /dev-python/build
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest4
-rw-r--r--dev-python/build/build-0.8.0.ebuild68
-rw-r--r--dev-python/build/build-0.9.0.ebuild2
3 files changed, 2 insertions, 72 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 9719518bf4be..a45620bd4b24 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,5 +1,3 @@
-DIST build-0.8.0.gh.tar.gz 40020 BLAKE2B 17422c8fe23d4103c78bd9d98702646f0863abfea4ff5df425942eb71aa905d8171567976228681afa90f453131ccce4701128b4f73b61acf4158ea2758c5c9e SHA512 62eaabef36fae592b06c41623f8f36750a029263a65c8fa21ad58b24ef30d4fa8eef7588237a68efb9a9784676f35605a8c9a6b2ed1bc6844c32924f9b5ec377
DIST build-0.9.0.gh.tar.gz 41012 BLAKE2B 764338ffab3b6ede66542195271b1b07d1cff71685ae88bcef8042ce0a93a3a95a80a8a2273ac6a1534d8416410c8af77fdd3fe52fdacb47b8a56a9857ba60a2 SHA512 d6ef229c8f3b348cc939af6bd9a0a521a25c3a5702a95da8ee36d7a1ad3f3e22e10b5c96495ff08a1328ab73f03feebc64e89ce165862cb295eff4360c79d642
-EBUILD build-0.8.0.ebuild 2101 BLAKE2B 41059b2880d4716241cacbd696645111fc7bd1374541589c0253322f24afe3405424bc765cc86b81125e84de1dba7f9d2f44117f0d536a0848be8250d8122b5d SHA512 d5ec900c7ca060e6cca0abc8451e5d2336f58f08f0a3aeb1e28cdde1a4c099e3dc4c31fc8ab0bd203ccdc095e9e6f284f368f9a82f16da298d8f95ad99b532c3
-EBUILD build-0.9.0.ebuild 2109 BLAKE2B f982fdcb4002ec564d82cf9bc1e51a70deb26bc681395224d2932f037e5443dccdfaa1d22b695fc0ab48fe588ffc672181d6a6d3c1e8d93178a10873874b5614 SHA512 3e06560a0a45001dd0edde622332593326d68e488a6df1520b41d487ef9f89133956ebfb6e295cb4e4ac834d9d1edceeeeeece3713ef91d3ff0217a1a7da47c6
+EBUILD build-0.9.0.ebuild 2101 BLAKE2B 41059b2880d4716241cacbd696645111fc7bd1374541589c0253322f24afe3405424bc765cc86b81125e84de1dba7f9d2f44117f0d536a0848be8250d8122b5d SHA512 d5ec900c7ca060e6cca0abc8451e5d2336f58f08f0a3aeb1e28cdde1a4c099e3dc4c31fc8ab0bd203ccdc095e9e6f284f368f9a82f16da298d8f95ad99b532c3
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.8.0.ebuild b/dev-python/build/build-0.8.0.ebuild
deleted file mode 100644
index 0aadcca52b3a..000000000000
--- a/dev-python/build/build-0.8.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/
-"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- tests/test_env.py::test_isolated_env_log
- tests/test_main.py::test_output_env_subprocess_error
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # Internet
- tests/test_main.py::test_build_package
- tests/test_main.py::test_build_package_via_sdist
- tests/test_self_packaging.py::test_build_sdist
- tests/test_self_packaging.py::test_build_wheel
- 'tests/test_util.py::test_wheel_metadata[True]'
- tests/test_util.py::test_with_get_requires
- # we don't really have to test that fallback
- # (requires dev-python/toml that we'd like to lastrite eventually)
- tests/test_projectbuilder.py::test_toml_instead_of_tomli
- )
-
- epytest -p no:flaky -n "$(makeopts_jobs)" \
- -W"ignore:path is deprecated.:DeprecationWarning"
-}
diff --git a/dev-python/build/build-0.9.0.ebuild b/dev-python/build/build-0.9.0.ebuild
index df040676ce48..0aadcca52b3a 100644
--- a/dev-python/build/build-0.9.0.ebuild
+++ b/dev-python/build/build-0.9.0.ebuild
@@ -19,7 +19,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/packaging-19.0[${PYTHON_USEDEP}]