summaryrefslogtreecommitdiff
path: root/dev-python/cached-property
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/cached-property
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/cached-property')
-rw-r--r--dev-python/cached-property/Manifest3
-rw-r--r--dev-python/cached-property/cached-property-1.5.1.ebuild22
-rw-r--r--dev-python/cached-property/files/cached-property-1.5.1-test-failure.patch10
3 files changed, 25 insertions, 10 deletions
diff --git a/dev-python/cached-property/Manifest b/dev-python/cached-property/Manifest
index fa2e315e1e10..b9253d97814e 100644
--- a/dev-python/cached-property/Manifest
+++ b/dev-python/cached-property/Manifest
@@ -1,3 +1,4 @@
+AUX cached-property-1.5.1-test-failure.patch 366 BLAKE2B 1df343e43fb74df2913c222d2a1f37e703de34480e325df68feee7575682005be6d0f41f34e553c3ec2cde11c6907b1d79a73e67ac88c5691e366b7bc64d6970 SHA512 bf005bbb986140dab7949e015ee9453081b72a9c377b6f330f8ffac10f73d7ec0e2a2e20c9d65879c3c18b3c4b2735b3329b30f48e1e4bd01ece475833f2a58c
DIST cached-property-1.5.1.tar.gz 12791 BLAKE2B dcc75564d3b1dbb2f34ea433f4a477b2fe0454047f1fb4825cc6350458bf09509cf970b308744d79eb3b17f96c04c606ad36327c7e24f0b13f412880d9ad2ab7 SHA512 61bbedb48336af7c0b465421eb4d3b6b48155cfe4fd6270ff49caefe0d80e40b50c4801a68a5564931d316e374b69112ad14f72687a015ce81aaeade6fcf9ce3
-EBUILD cached-property-1.5.1.ebuild 606 BLAKE2B b8449f4a1ba07484210bde520bc1c0e25c4726d9b77299df358b5f1199ee74b220aee2fa6a6c4acb3e541bac18678c89c0feaabd345f7c8810b875f02d80caed SHA512 2c95c66556fb71c1fe35334a4b22547b5b00c9091510ff6067c4ca6bbb4fa41fbda944057fe2cb9cb45b9c73fc5c9623e5c305179d539e6546c75a020000cbb8
+EBUILD cached-property-1.5.1.ebuild 727 BLAKE2B fa754a05805aee91ea5b02d1a478b03e79bcbe9a2787fc10bfd237bc6e07e0b712d20e740d3ad5aba108bde97547a275aa15d2fc3c6c8f310ddded64a8d19974 SHA512 1359667eae48f4cd9abbd8c6b09139ee6e41179c5806d0971387607f58f1ad5c66f7a2ac630050e6a75e43ff566302e949b98fb8b3a65560345bea0bf98cf112
MISC metadata.xml 486 BLAKE2B e012a6b1d4e8ab99e6f89b18a31d548b5e26887dcf7985cf5a6c500fe4a751c7e2f4b0a055e8afa9ba09ab20af3cdd206c902521f878872e920858a3b9f649cc SHA512 8c3e98d3d89a58505c4cf4a1cb15559c43be2a184bdd4cd696b023f58001cb65064ddb938ea792c51fd29808512bbfb30580ff2ac9509aab92e0c53c4de08afc
diff --git a/dev-python/cached-property/cached-property-1.5.1.ebuild b/dev-python/cached-property/cached-property-1.5.1.ebuild
index 01da4c80d703..04b4c9817683 100644
--- a/dev-python/cached-property/cached-property-1.5.1.ebuild
+++ b/dev-python/cached-property/cached-property-1.5.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,15 +15,18 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc64 x86"
-DEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
+DEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
-src_install() {
- distutils-r1_src_install
+python_prepare_all() {
+ # bug 638250
+ eapply "${FILESDIR}"/${PN}-1.5.1-test-failure.patch
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
+ distutils-r1_python_install_all
}
diff --git a/dev-python/cached-property/files/cached-property-1.5.1-test-failure.patch b/dev-python/cached-property/files/cached-property-1.5.1-test-failure.patch
new file mode 100644
index 000000000000..03fabd2900ca
--- /dev/null
+++ b/dev-python/cached-property/files/cached-property-1.5.1-test-failure.patch
@@ -0,0 +1,10 @@
+--- a/tests/test_cached_property.py
++++ b/tests/test_cached_property.py
+@@ -191,6 +191,7 @@
+ self.assert_cached(check, 2)
+ self.assert_cached(check, 2)
+
++ @unittest.skip("Gentoo Bug #638250")
+ def test_threads_ttl_expiry(self):
+ Check = CheckFactory(self.cached_property_factory(ttl=100000), threadsafe=True)
+ check = Check()