summaryrefslogtreecommitdiff
path: root/dev-python/cached-property
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cached-property
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cached-property')
-rw-r--r--dev-python/cached-property/Manifest5
-rw-r--r--dev-python/cached-property/cached-property-1.3.1.ebuild31
-rw-r--r--dev-python/cached-property/cached-property-1.4.2.ebuild39
-rw-r--r--dev-python/cached-property/metadata.xml15
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/cached-property/Manifest b/dev-python/cached-property/Manifest
new file mode 100644
index 000000000000..35eb3efa230f
--- /dev/null
+++ b/dev-python/cached-property/Manifest
@@ -0,0 +1,5 @@
+DIST cached-property-1.3.1.tar.gz 9648 BLAKE2B 154208108cfbec914519f2a08ecc6ad025c284726d65a001eae84701b1eb8479e127473c124b08d3b0d969f59798f9dcef473cd8209c248b1d5b016a0bc8dac6 SHA512 3349751d442ca6e7d4e792c8b076735d5308d68244af9c03044f3d72d619a5c3d7d5dbef434caa954db4b983245bfe646d4a25c99aec39f32d99751edd9e233f
+DIST cached-property-1.4.2.tar.gz 11201 BLAKE2B 1fba572e8e4e06744b230994e19a93f9004c0e2584549af2b001cf780222cbd2196b09432301f1ef8b4c4ccc93f8dedf53113c541b1189bc005c79fa9d7dadc0 SHA512 27ce49c8b71f0337e34c36ef5a45cae273a62b42c8f1b690c2c4d32d9bdf7f532a12787c99257c956ac7ff15d2e7f16868e4cebdf1417ebca493e1037c1a612f
+EBUILD cached-property-1.3.1.ebuild 625 BLAKE2B d05f358db313bb62e8e6af7733fbeb9bb378db4ebe34be8d2c44da08147aed09567c8dea352c93ee3a94ca6ac52733b19c5ddfaa119795d9f515c1b9a0972093 SHA512 8b408e180af71d702e053ee0e56327eeae8843ca3b75e15b71d41997a428ce63c59f04e74e59edd93f4898e99280f39dd5f37ef1c64ae8e30d33404a22802547
+EBUILD cached-property-1.4.2.ebuild 911 BLAKE2B 252e6b963254b1e48cd328adc04bf344f2916145ff9138f15d780e8196215feabbd3ed524a2d26922fdeae5d20c1011633c11087f0096ad81c0afc45e7946361 SHA512 442dcfa206d8f8b06bdef561723ec280692f7e6cfd35dca8d36335687a7b9668b84acaa9a034d5c24cd2d2c4f7836fb64197d6ab8faad80c04fbdec8daca2416
+MISC metadata.xml 489 BLAKE2B 36f59b8764462acd2920868cc5b5c84e27cf2e86b1356a76a816ec60a5f69bda780a62a811aefe06639827bdc3257128cded2d6c2e53e8c4516af9d1b9769879 SHA512 cecc6d43fcd54d1a949a60380d91a313d0464e0858be0fd544a76232f04961eca2530ebddaf6daabc5f050bdfe12092c99028c4a9cd33a14f23c0b43befe7def
diff --git a/dev-python/cached-property/cached-property-1.3.1.ebuild b/dev-python/cached-property/cached-property-1.3.1.ebuild
new file mode 100644
index 000000000000..34c9ffcc1114
--- /dev/null
+++ b/dev-python/cached-property/cached-property-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A cached-property for decorating methods in classes"
+HOMEPAGE="https://github.com/pydanny/cached-property"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/pytest
+ dev-python/freezegun
+ )"
+RDEPEND=""
+
+src_install() {
+ distutils-r1_src_install
+ dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
+}
+
+python_test() {
+ py.test || die
+}
diff --git a/dev-python/cached-property/cached-property-1.4.2.ebuild b/dev-python/cached-property/cached-property-1.4.2.ebuild
new file mode 100644
index 000000000000..3b54319a6d39
--- /dev/null
+++ b/dev-python/cached-property/cached-property-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A cached-property for decorating methods in classes"
+HOMEPAGE="https://github.com/pydanny/cached-property"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/pytest
+ dev-python/freezegun
+ )"
+RDEPEND=""
+
+src_install() {
+ distutils-r1_src_install
+ dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
+}
+
+python_test() {
+ local ignore=""
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ ignore="--ignore=tests/test_coroutine_cached_property.py \
+ --ignore=tests/test_async_cached_property.py"
+ fi
+ if [[ ${EPYTHON} == python3.4 ]]; then
+ ignore="--ignore=test_async_cached_property.py"
+ fi
+ py.test -v ${ignore} tests/ || die
+}
diff --git a/dev-python/cached-property/metadata.xml b/dev-python/cached-property/metadata.xml
new file mode 100644
index 000000000000..39f7deddac0c
--- /dev/null
+++ b/dev-python/cached-property/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ A cached-property for decorating methods in classes.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">cached-property</remote-id>
+ <remote-id type="github">pydanny/cached-property</remote-id>
+ </upstream>
+</pkgmetadata>