summaryrefslogtreecommitdiff
path: root/dev-python/carbon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
commit6c9dc10e04cd513437e046ccca0e51a3d6d4dc7c (patch)
treeb7183e321a607f857cc5c62cfbd5bae7cbfb3982 /dev-python/carbon
parent66113e7871aede225d661473925cea4cce9e6d23 (diff)
gentoo auto-resync : 17:05:2024 - 00:01:35
Diffstat (limited to 'dev-python/carbon')
-rw-r--r--dev-python/carbon/Manifest5
-rw-r--r--dev-python/carbon/carbon-1.1.10.ebuild61
-rw-r--r--dev-python/carbon/files/carbon.confd5
-rw-r--r--dev-python/carbon/files/carbon.initd253
-rw-r--r--dev-python/carbon/metadata.xml15
5 files changed, 0 insertions, 139 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
deleted file mode 100644
index c80797102618..000000000000
--- a/dev-python/carbon/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX carbon.confd 119 BLAKE2B 75505b3aedcc65306a1cd16645e349012652a268d838dc1fd32d8a143d18dfca3c9e3233a0bfcdeee22a26592bb49408a3e4708d96796361219f73dc5e32adb4 SHA512 049d2e3c9e9ae9375f485568185b14fb326a85f13a5f40e19a5d26aaecd0b98a61f011dbe4335110b6e3314ec52d308fea8f577df8b29b5d675fd7763a02788f
-AUX carbon.initd2 1329 BLAKE2B 7990f8ee25f2554ce5997075c7fda4cfc69d73ae060657a917498bed4ef237a6e0b43b522ef15b0587d15c71fdb03a26f562d1147212c50f8d838f97522cc9cd SHA512 08d9a7ddc763bb49763b1c873504b0dfb45763ed871f22632885692f41d5d8c86616677c2669b0b8c2160170a7c507c2415571d300e2045675c7002556a4063e
-DIST carbon-1.1.10.tar.gz 77091 BLAKE2B 367beb81a4dcf4c5fff6bf9884c7accb8aea9daa88d6d890bb977c926268b7ae041c9ac8e4b537f07d08d6c970f536ccc87ae6b4caef555883aadeab155fedce SHA512 a5c8d730e311bb65682c701b79a5e3e02e35eec5c0d923fece3f63d7036ca1f85775100fba9a2090487f2cf75bae7708dae9580deccd8fc586f2820b03e14b4c
-EBUILD carbon-1.1.10.ebuild 1933 BLAKE2B 3caa6b4f2fcd1f39455136add9e2cfefd303f8cc6f30675d53026a8ab65e62c0ec5f4fe8c3aa8a6e0222f07f9fefa88e31c9a7b75f5743df19f9d30775ad8c1e SHA512 fe3d789c0e46372c768eb4ac8b34fc4fcedff5f963c8a6a2e21466b70c2fcc60f26d0529c068aadd627c9b94ccf71ca0f0d621a8aaf8ed60d40df5fc69454e42
-MISC metadata.xml 442 BLAKE2B e3ab8eb53738bdacc8fb73e7514c28290609200a34d6d6fc0111e30bd44d7806f91a4c3906cf473f8dc58b6d8012ecdaf320d943f770d05e26f3b0b44d99a57f SHA512 0deb6d56a05c7b0ee70787dad985a0f250d8328c1edd54690092dceeab8ba90e96ec2ddb326202f01eeb702776e448b746a5c92392ea02cba1892155d3eb60ec
diff --git a/dev-python/carbon/carbon-1.1.10.ebuild b/dev-python/carbon/carbon-1.1.10.ebuild
deleted file mode 100644
index 72cc0318ec8d..000000000000
--- a/dev-python/carbon/carbon-1.1.10.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backend data caching and persistence daemon for Graphite"
-HOMEPAGE="https://graphiteapp.org/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-# whisper appears to have been missed from listing in install_requires in setup.py
-RDEPEND="
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Do not install the configuration and data files. We install them
- # somewhere sensible by hand.
- sed -i -e '/data_files=install_files,/d' setup.py || die
- # We want FHS-style paths instead of /opt/graphite
- export GRAPHITE_NO_PREFIX=yes
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/carbon
- doins conf/*
-
- keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
-
- newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
- newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
- newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
-
- newconfd "${FILESDIR}"/carbon.confd carbon-cache
- newconfd "${FILESDIR}"/carbon.confd carbon-relay
- newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
-}
-
-pkg_postinst() {
- einfo 'This ebuild installs carbon into FHS-style paths.'
- einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
- einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
- einfo '(see /etc/carbon/carbon.conf.example).'
- einfo ' '
- einfo 'OpenRC init script supports multiple instances !'
- einfo 'Example to run an instance b of carbon-cache :'
- einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
- einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
-}
diff --git a/dev-python/carbon/files/carbon.confd b/dev-python/carbon/files/carbon.confd
deleted file mode 100644
index b1875e134678..000000000000
--- a/dev-python/carbon/files/carbon.confd
+++ /dev/null
@@ -1,5 +0,0 @@
-# Use the given config file
-CARBON_CONFIG="/etc/carbon/carbon.conf"
-
-# Add extra parameters
-CARBON_EXTRA_PARAMETERS=""
diff --git a/dev-python/carbon/files/carbon.initd2 b/dev-python/carbon/files/carbon.initd2
deleted file mode 100644
index ff1509747ef1..000000000000
--- a/dev-python/carbon/files/carbon.initd2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-export GRAPHITE_CONF_DIR=/etc/carbon
-export GRAPHITE_STORAGE_DIR=/var/lib/carbon
-
-INSTANCE=${SVCNAME#*.}
-if [ "${INSTANCE}" = "${SVCNAME}" ]; then
- INSTANCE="a"
-fi
-
-PIDFILE="/var/run/${SVCNAME}.pid"
-PROGRAMNAME=${SVCNAME%%.*}
-
-CARBON_CONFIG=${CARBON_CONFIG:-/etc/carbon/carbon.conf}
-
-depend() {
- use net
-}
-
-
-start_pre() {
- if [ ! -f ${CARBON_CONFIG} ] ; then
- eend "Missing ${CARBON_CONFIG}"
- fi
- case "${PROGRAMNAME}" in
- "carbon-relay" )
- if `grep -q "^RELAY_METHOD = rules$" ${CARBON_CONFIG}`; then
- [ -f /etc/carbon/relay-rules.conf ] || eend "Missing relay-rules.conf"
- fi
- ;;
- "carbon-aggregator" )
- [ -f /etc/carbon/aggregation-rules.conf ] || eend "Missing missing aggregation-rules.conf"
- ;;
- esac
-}
-
-start() {
- ebegin "Starting ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --start --exec /usr/bin/${PROGRAMNAME}.py \
- --pidfile ${PIDFILE} \
- -- --pidfile ${PIDFILE} --instance ${INSTANCE} \
- --logdir /var/log/carbon/ --config ${CARBON_CONFIG} start >/dev/null
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- ebegin "Stopping ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --stop \
- --pidfile ${PIDFILE}
- eend $? "Failed to stop ${SVCNAME}"
-}
diff --git a/dev-python/carbon/metadata.xml b/dev-python/carbon/metadata.xml
deleted file mode 100644
index d38ab1927158..000000000000
--- a/dev-python/carbon/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
- <maintainer type="person">
- <email>grobian@gentoo.org</email>
- <name>Fabian Groffen</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">carbon</remote-id>
- </upstream>
-</pkgmetadata>