summaryrefslogtreecommitdiff
path: root/dev-python/castellan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/castellan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/castellan')
-rw-r--r--dev-python/castellan/Manifest5
-rw-r--r--dev-python/castellan/castellan-0.12.2.ebuild41
-rw-r--r--dev-python/castellan/castellan-0.17.0.ebuild38
-rw-r--r--dev-python/castellan/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
new file mode 100644
index 000000000000..32c90e53fcd1
--- /dev/null
+++ b/dev-python/castellan/Manifest
@@ -0,0 +1,5 @@
+DIST castellan-0.12.2.tar.gz 50938 BLAKE2B 03cec0cd85042c482432bef7a0115413a9ea03aab05555dc1d4a65b5cb9893b57e2164a5174fb984c8ffcd190b27f9c26552dc242f9d79e3d60dce5a4a27479e SHA512 11ed1eb7fa1e5721f26afe23299ac7b0d13b4570b1f0670f4b13ac05149bdb9b9daa85cd1b29374f7d67eaa22957088b2f42313e23d8c0adf4edef108f7b44d9
+DIST castellan-0.17.0.tar.gz 61193 BLAKE2B 91f9a4d6b495bd4bb8f1f00a9b2435a892a7ea2f6f64d36423aee3c87250deda73cdcb2070e12cb1c38c5ca716c4365d489990e7b07f35fa7e6e597eda442af7 SHA512 21b702cf73cf62456d677d01706f23e9d64c726d06d867d61559b0b221e016f519c067c1f10e540fb25bb73841ef633b7b4a602ed13ae64456aaa4843ee19c53
+EBUILD castellan-0.12.2.ebuild 1434 BLAKE2B d23c0765675a60ffd82635bfac4d3f035665550ca899186818436b1892b2d1fc569bf226675d5e9107b9784ae12916996c1b0e5bfde00e54d9f266f40acb1fd5 SHA512 843eac6daa1595015495c61fe1b3b52c56338d98431b57caf2d09187d718658d1e82e5379902114872aa59531004ebeebb565f08291cec0f340e6e604946f999
+EBUILD castellan-0.17.0.ebuild 1282 BLAKE2B 1068c8c400957b9cf37190d8f051b7843af1b17361f2331d23baffb38ac23b7c79b6f38510614cd4f97a9cd5489ef803b3be2737adc4f1194b27add11596418b SHA512 2592b2cf92ee296917fb5b0fb1d6352da65a70364040ccd9a78419e80ec44bd77ebce10007c4a5cca45614cc2cb548709037d884570a2f16e92f32955cb9173b
+MISC metadata.xml 326 BLAKE2B 5ce95fc1eeafa570c9910dd492a822dfeb251bb98c5b341281ee99e7402be32234fc38bbca1b7ea0fbb67f8bc88e9b1a1c85da73f79d2a9ffc3a69289da507b4 SHA512 f8d928ab94ac70a7a3c2548b67a6296b8e86b5e239a9c74cc4b1a120f64c1e2e2084612b025e26fa3c02099f543ce156e5419a5f6ea165eff79b2dd77e9a2d66
diff --git a/dev-python/castellan/castellan-0.12.2.ebuild b/dev-python/castellan/castellan-0.12.2.ebuild
new file mode 100644
index 000000000000..af3a46cafef3
--- /dev/null
+++ b/dev-python/castellan/castellan-0.12.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.org/project/castellan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/castellan/castellan-0.17.0.ebuild b/dev-python/castellan/castellan-0.17.0.ebuild
new file mode 100644
index 000000000000..b522983852c8
--- /dev/null
+++ b/dev-python/castellan/castellan-0.17.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.org/project/castellan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.9[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/castellan/metadata.xml b/dev-python/castellan/metadata.xml
new file mode 100644
index 000000000000..c9cdba5de5c2
--- /dev/null
+++ b/dev-python/castellan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">castellan</remote-id>
+ </upstream>
+</pkgmetadata>