summaryrefslogtreecommitdiff
path: root/dev-python/castellan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/castellan
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/castellan')
-rw-r--r--dev-python/castellan/Manifest2
-rw-r--r--dev-python/castellan/castellan-0.17.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
index ff27f4dcfbaa..32d889c858fe 100644
--- a/dev-python/castellan/Manifest
+++ b/dev-python/castellan/Manifest
@@ -1,3 +1,5 @@
DIST castellan-0.12.2.tar.gz 50938 BLAKE2B 03cec0cd85042c482432bef7a0115413a9ea03aab05555dc1d4a65b5cb9893b57e2164a5174fb984c8ffcd190b27f9c26552dc242f9d79e3d60dce5a4a27479e SHA512 11ed1eb7fa1e5721f26afe23299ac7b0d13b4570b1f0670f4b13ac05149bdb9b9daa85cd1b29374f7d67eaa22957088b2f42313e23d8c0adf4edef108f7b44d9
+DIST castellan-0.17.0.tar.gz 61193 BLAKE2B 91f9a4d6b495bd4bb8f1f00a9b2435a892a7ea2f6f64d36423aee3c87250deda73cdcb2070e12cb1c38c5ca716c4365d489990e7b07f35fa7e6e597eda442af7 SHA512 21b702cf73cf62456d677d01706f23e9d64c726d06d867d61559b0b221e016f519c067c1f10e540fb25bb73841ef633b7b4a602ed13ae64456aaa4843ee19c53
EBUILD castellan-0.12.2.ebuild 1437 BLAKE2B a4259d9f6405ebad390042c67b437d3dd156dbe28d07eb37dc3e5d2c9551e5395c8782cc33ef23f9846caf1c55ecceb1471f953277c7d62e88c3c97b59101654 SHA512 2c6d7918c1e5987d9df0e777c0a98aceae41cf05c10854e4e32bcff25fb2b8ce7bf1ff54c112b8612225390e33e6e0af9e0dc2def7a29d7500046536c7393a2c
+EBUILD castellan-0.17.0.ebuild 1291 BLAKE2B fb199e71b3651d85a33831c74d888b57d001720f0bf2aeb72355931f7b84be57ffaf48ed0f27a3009fcea67737953f7c55369a4c74fd773a51644d6f81ececcd SHA512 74fc3aaf6df1ccd99381cfdcce73b715105dbf4b54b2884fb479509b51807e55e226e73a2b46d3117023dfc0bbb5912fa8122a31c938c1aa551855b3033a153f
MISC metadata.xml 326 BLAKE2B 5ce95fc1eeafa570c9910dd492a822dfeb251bb98c5b341281ee99e7402be32234fc38bbca1b7ea0fbb67f8bc88e9b1a1c85da73f79d2a9ffc3a69289da507b4 SHA512 f8d928ab94ac70a7a3c2548b67a6296b8e86b5e239a9c74cc4b1a120f64c1e2e2084612b025e26fa3c02099f543ce156e5419a5f6ea165eff79b2dd77e9a2d66
diff --git a/dev-python/castellan/castellan-0.17.0.ebuild b/dev-python/castellan/castellan-0.17.0.ebuild
new file mode 100644
index 000000000000..8f408674d4b7
--- /dev/null
+++ b/dev-python/castellan/castellan-0.17.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.9[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+"