summaryrefslogtreecommitdiff
path: root/dev-python/celery/celery-4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/celery/celery-4.1.0.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/celery/celery-4.1.0.ebuild')
-rw-r--r--dev-python/celery/celery-4.1.0.ebuild109
1 files changed, 0 insertions, 109 deletions
diff --git a/dev-python/celery/celery-4.1.0.ebuild b/dev-python/celery/celery-4.1.0.ebuild
deleted file mode 100644
index 623202a77643..000000000000
--- a/dev-python/celery/celery-4.1.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
-HOMEPAGE="http://celeryproject.org/ https://pypi.org/project/celery/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# There are a number of other optional 'extras' which overlap with those of kombu, however
-# there has been no apparent expression of interest or demand by users for them. See requires.txt
-IUSE="doc examples redis sqs test yaml"
-RESTRICT="!test? ( test )"
-
-# kombu < 4.2: #666228 (can be loosened in next bump)
-RDEPEND="
- <dev-python/kombu-4.2[${PYTHON_USEDEP}]
- >=dev-python/kombu-4.0.2[${PYTHON_USEDEP}]
- >=dev-python/billiard-3.5.0.2[${PYTHON_USEDEP}]
- <dev-python/billiard-3.6.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/vine[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/gevent[$(python_gen_usedep python2_7)]
- >=dev-python/pymongo-2.6.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
- >=dev-db/redis-2.8.0
- >=dev-python/boto-2.13.3[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/unittest2-0.5.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.3[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python2_7)
- )"
-
-# testsuite needs it own source
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- mkdir docs/.build || die
- emake -C docs html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd-r2" celery
- newconfd "${FILESDIR}/celery.confd-r2" celery
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- newbashcomp extra/bash-completion/celery.bash ${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "zookeeper support" dev-python/kazoo
- optfeature "msgpack support" dev-python/msgpack
- #optfeature "rabbitmq support" dev-python/librabbitmq
- #optfeature "slmq support" dev-python/softlayer_messaging
- optfeature "eventlet support" dev-python/eventlet
- #optfeature "couchbase support" dev-python/couchbase
- optfeature "redis support" dev-db/redis dev-python/redis-py
- optfeature "gevent support" dev-python/gevent
- optfeature "auth support" dev-python/pyopenssl
- optfeature "pyro support" dev-python/pyro:4
- optfeature "yaml support" dev-python/pyyaml
- optfeature "memcache support" dev-python/pylibmc
- #optfeature "threads support" dev-python/threadpool
- optfeature "mongodb support" dev-python/pymongo
- optfeature "sqlalchemy support" dev-python/sqlalchemy
- optfeature "sqs support" dev-python/boto
- #optfeature "cassandra support" dev-python/pycassa
-}