summaryrefslogtreecommitdiff
path: root/dev-python/cerberus/cerberus-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/cerberus/cerberus-1.3.2.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/cerberus/cerberus-1.3.2.ebuild')
-rw-r--r--dev-python/cerberus/cerberus-1.3.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cerberus/cerberus-1.3.2.ebuild b/dev-python/cerberus/cerberus-1.3.2.ebuild
new file mode 100644
index 000000000000..bb8115a7763d
--- /dev/null
+++ b/dev-python/cerberus/cerberus-1.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight and extensible data-validation library for Python"
+HOMEPAGE="https://docs.python-cerberus.org/"
+SRC_URI="https://github.com/pyeve/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2_no-pytest-runner.patch
+)
+
+distutils_enable_tests pytest