summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
commitcd8b6c60f3cbb06647bf3d03fb2ac29ccfc31c8f (patch)
tree2e3b9d43dc19a31fee73728c8a91e2e02e6b243e /dev-python/cfn-lint
parent62ce4dfbf01c603a668dabde87ccc5b4ca4069af (diff)
gentoo auto-resync : 14:11:2023 - 10:30:49
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.83.2.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 67eb0979967b..ec228767851a 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.82.2.tar.gz 3714901 BLAKE2B 76077d606ac645953f71fadf5b096e3a8e4a6e7c71b25af9647e0c155f40790ded2d96af93b959c00641475481758abc7af215cfe1004aeb05c90f3e85210bde SHA512 91f93ffcf39883dfe8bb8e15298bf9bfec4c952762b9fec162107ecf70f5a11c44baa1ea3121db9f710375b3ab5afe11dca7142251ba070835c80accf0e41d9d
DIST cfn-lint-0.83.1.tar.gz 3656263 BLAKE2B 337352a7ba725267974ec41a5d7b6088fbf817e019429baca48feb7f19c0a5963d23df396b3c018194642068a569c995a7ae63a77ba17b66685a02b59eba1fcd SHA512 a97968a46180550f71ffca7bfb22b4e2a90eba186dd2f426ba7b3812cb457ad8bfbdc359182fd6d93b27b2937c15567c90e47d06285898bbc63baea50b4d293f
+DIST cfn-lint-0.83.2.tar.gz 3676910 BLAKE2B 058a2590c5c7bffa5144e6ce0c2dd1fbc63c999253d249e5425d0b87b12baf77dd94e1f11387516b01ffbbcffafe9a08f1d43e5025168c1c9c5bef726eafbd10 SHA512 dd20dabfb2a1132085570a0cbdad5899953d0780d569eda0f403ded0dead919de3125094f7bfc36d2b4fc69826767ebca67a8393a4e21d2a3e33313766b2b697
EBUILD cfn-lint-0.82.2.ebuild 2066 BLAKE2B 424b3ba929924d4af94c1f5431cf03f4b3f4806059f2fe517f5b9cb1521299fc237cee0354bc04f6719ce79a585033bcebe39783cdb27de348f76e037a51af29 SHA512 56faa1fa8a2f8dd99a2a4f0b4317e542feeca137fbe55871d5bafa35c0d26e82659119c82ea2021f8a122b4ae05320906a50a32b55ad0f23935c58528642c369
EBUILD cfn-lint-0.83.1.ebuild 2200 BLAKE2B ef7f7cd6829fb9b48980e5d242da95883c1f4eb5573864f061f243460c5b384dacfce506ab99ab50f36e09058cd74431217438b594cdf9f69347fdcec39f754b SHA512 a9e7635df1f6c1818a9c5ae0481486c820408e8ba817ed12e1728e7843ba1b46c7c4257825304dace919b46d35aadec5ece425859ec1171959ed2ba6e0b18861
+EBUILD cfn-lint-0.83.2.ebuild 2200 BLAKE2B ec7626a51447f77472459606e0938e202dd954a05c0f3d605796413a632c787ba45905db092a84b2543f4ed6e9d490b28ee5b9cbccfa7776c30c584c5ac125cc SHA512 46a2aa3d70f8e1f964fc8588b2c06910bd8ae5fdf23e140595751cd2b372148b757684ceca998c2fbca491fd97939ea504a9e946afdbd4433b51f14976e8b640
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
new file mode 100644
index 000000000000..787cd17c5e65
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.83.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.79.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}