summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/cfn-lint
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.5-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 42ce61f47faa..5c5bb0566287 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -5,5 +5,6 @@ DIST cfn-lint-0.72.5.gh.tar.gz 3220306 BLAKE2B 381b069e4d35d9af8fa7bab9765f3b249
EBUILD cfn-lint-0.71.1.ebuild 1638 BLAKE2B d6f1eb649359ad720f936be2dcefbd7c0f0106624e1189dd7af84a690255aba1faf6cfe40e441a51560b66b4b49e1d91e02e3a6cf293dfa5b9bd6132f7349922 SHA512 aec08fc4886ee20dfab104e0c9829bd7a19c85d84dec6262a909a138a56b7eb441177c40fed1cdfc0c7f5cba89edabce9a2328135bccf3d1fde0dae3fc7e6a28
EBUILD cfn-lint-0.72.2.ebuild 1640 BLAKE2B 0e316501d527a704dcbd50724505468c906e84e00c9861ae701b176db497b6c67072283627bc1200759429896d58ac6a0007ef4dfd7dd1bc8ee9b4e417eed64d SHA512 2faaaa66c9015dc80c36392a03747515fc42985129d8f9aa02a2a9d14235c60eb803996c923ffb01f2c776b1f20b8ca3e2a931a5aa5f2f1fbf93eb5361eb69ed
EBUILD cfn-lint-0.72.4.ebuild 1640 BLAKE2B 0e316501d527a704dcbd50724505468c906e84e00c9861ae701b176db497b6c67072283627bc1200759429896d58ac6a0007ef4dfd7dd1bc8ee9b4e417eed64d SHA512 2faaaa66c9015dc80c36392a03747515fc42985129d8f9aa02a2a9d14235c60eb803996c923ffb01f2c776b1f20b8ca3e2a931a5aa5f2f1fbf93eb5361eb69ed
+EBUILD cfn-lint-0.72.5-r1.ebuild 1641 BLAKE2B dd94047b565367ce0f7a48966806b902f475027e116a4fa8245a9bd5cfc4229b9e9aed623e32e46ae7d991af0180852c1ea77a4f99f144249625d8c1115c235c SHA512 103c3dacd45f8d3513887d5e5cabcf76a7b6a5e77d12581a4e940bcf760bbb936c9f202b9cb6a6eb78c9e5e56b7bf9af4e9daeaf60250cdfebf57a782b32b01b
EBUILD cfn-lint-0.72.5.ebuild 1640 BLAKE2B 0e316501d527a704dcbd50724505468c906e84e00c9861ae701b176db497b6c67072283627bc1200759429896d58ac6a0007ef4dfd7dd1bc8ee9b4e417eed64d SHA512 2faaaa66c9015dc80c36392a03747515fc42985129d8f9aa02a2a9d14235c60eb803996c923ffb01f2c776b1f20b8ca3e2a931a5aa5f2f1fbf93eb5361eb69ed
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.5-r1.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.5-r1.ebuild
new file mode 100644
index 000000000000..917b8b87c0f1
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.72.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.55.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}