summaryrefslogtreecommitdiff
path: root/dev-python/cheetah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cheetah
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/Manifest3
-rw-r--r--dev-python/cheetah/cheetah-2.4.4-r1.ebuild44
-rw-r--r--dev-python/cheetah/metadata.xml15
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/cheetah/Manifest b/dev-python/cheetah/Manifest
new file mode 100644
index 000000000000..61e6e13cb412
--- /dev/null
+++ b/dev-python/cheetah/Manifest
@@ -0,0 +1,3 @@
+DIST Cheetah-2.4.4.tar.gz 190989 BLAKE2B 567aee718199021c3de725376da37b2f28081cf8741d1af201f7e6e88e026f460c10f3502463d58285a1340e308c718f709d437185f99f22c11f76c586ba4a60 SHA512 11b8cbf7d71789d6ae83596b133ddbe0bf1ccf2bca4c59562e7cd1d9bb75fa9d3208c0021d7d77edafdb03fd399cf1a26c003267fbffb94f27bf4457b0f9234c
+EBUILD cheetah-2.4.4-r1.ebuild 1193 BLAKE2B e47805eeaed621c5a32823fe04ab903b31cb6ef40d3f7236ff182f610a2f1281a8789a06a4c05b9f2586481d8ae21daafd3ce14597bdb5b02be576d8043cd1c0 SHA512 83bd9a1828f2e30b265b55923a5c2b49c621471de439ae390b1b1caa0ea57246df6564fe4a3c7d2ebeae1a765c39f1652ec59ce67968df6663aaeb7ff28f1509
+MISC metadata.xml 661 BLAKE2B 2808adeb2392976f9343fddfeab9f9494ba8eb4690c77b71c4f66434459d01eb8755f7ff1c97669f84a9e8e4b158fae2d0b69d3b2fccd6f4dacfb0e67bcbd629 SHA512 7c0f9ab56f056a5b878572b16991039ef79e009a50afc44e7e9745051d58d99f4c3f7c3c427f8a165a9a54e76983cb9cc5cd16f0e3629d85e5288b71eb0f38b6
diff --git a/dev-python/cheetah/cheetah-2.4.4-r1.ebuild b/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
new file mode 100644
index 000000000000..93980236036a
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.4.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Cheetah"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="http://www.cheetahtemplate.org/ https://rtyler.github.com/cheetah/ https://pypi.org/project/Cheetah/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+IUSE=""
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+SLOT="0"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES README.markdown TODO )
+# Race in the test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
+ -i cheetah/Tests/Test.py || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" cheetah/Tests/Test.py || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/cheetah/metadata.xml b/dev-python/cheetah/metadata.xml
new file mode 100644
index 000000000000..af1e88f2ab32
--- /dev/null
+++ b/dev-python/cheetah/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>Cheetah is a Python-powered template engine and code generator. It can be used
+as a standalone utility or it can be combined with other tools. Web developers
+are its principle user group, but it has many potential uses and is also being
+used to generate C++ game code, Java, SQL, form emails, and even Python code.</longdescription>
+ <upstream>
+ <remote-id type="pypi">Cheetah</remote-id>
+ </upstream>
+</pkgmetadata>