summaryrefslogtreecommitdiff
path: root/dev-python/cheroot/cheroot-8.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/cheroot/cheroot-8.5.2.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/cheroot/cheroot-8.5.2.ebuild')
-rw-r--r--dev-python/cheroot/cheroot-8.5.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/cheroot/cheroot-8.5.2.ebuild b/dev-python/cheroot/cheroot-8.5.2.ebuild
index ad187eb5f9bd..7e8619853279 100644
--- a/dev-python/cheroot/cheroot-8.5.2.ebuild
+++ b/dev-python/cheroot/cheroot-8.5.2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
HOMEPAGE="https://cherrypy.org/
https://pypi.org/project/cheroot/
https://github.com/cherrypy/cheroot/"
@@ -57,5 +56,5 @@ python_prepare_all() {
python_test() {
cd "${BUILD_DIR}" || die
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ epytest
}