summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/cheroot
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest1
-rw-r--r--dev-python/cheroot/cheroot-6.0.0-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 994095fcfba8..0fc46084f74c 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,3 +1,4 @@
DIST cheroot-6.0.0.tar.gz 62763 BLAKE2B 0946c01c6a6233dc60ca3dd896c3d1dbc0feb97d5099d88598db340a8812b2be4cb076383c0e39d30cd2c6fd3402e048b716a02e82bec8ce08d5b8fca4b1be0f SHA512 0109fbf3b73ed3f12261eaa3c6d86b6c6b80a1ba3564548ba3288aa6c61a1c08db60886e677991bf7997e6a5b1ec7767a3e06098ec1748453e72c40fda7b82a7
+EBUILD cheroot-6.0.0-r1.ebuild 925 BLAKE2B fc16e44b0f555c2e7e04ebdfa2fdfd9bd3f10f1e1efb23c38e5d8518da40db858d0c27d26126e70c51fd60143917c59fbe40fc45a0068a4aa1327706f79b63b9 SHA512 a8818fbc5af9b63e08a10b731cd11be8bae70282b2245677e3c96d4eeb4f90fb100f903267c33ddbcfb9c07da7631ce954bc84d74d1a33504a10c5ca53600d64
EBUILD cheroot-6.0.0.ebuild 931 BLAKE2B 53039d511b8884510ee22cb0f3cbf5c16bebcc2b1348deaa87af4b63cbeadd6f51e4110798c9669f286feef48b2bac678e2ca69cee6932f14d2561d655400c3a SHA512 5fe1f6b1eae632109fb51095a0e402acba031ab1ca90ace501d5da0b0ed3b86b6a2d6a7b80e6a776f27f28293f7538aaa3576aa40e683f74773bcb36d4ec0edb
MISC metadata.xml 370 BLAKE2B df7ec3eb606f1557e048245eca81402f40f9cd9bc4ec8112ecb0085f65530d9a66b952d56f826b2b97733018ec4b4d31c16ac26bebd3a40f3424421255fcb770 SHA512 22ff00c4677bd898e9d88f2bdebabed6a145a9dd33d6276e997c0435c64fc9dfd396a35a88c6facc8a3844187f0b598bfe8606637ea88420a6c33e1ea9765cbf
diff --git a/dev-python/cheroot/cheroot-6.0.0-r1.ebuild b/dev-python/cheroot/cheroot-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..8c5c6283880e
--- /dev/null
+++ b/dev-python/cheroot/cheroot-6.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="http://www.cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}