summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/cheroot
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest3
-rw-r--r--dev-python/cheroot/cheroot-6.5.4.ebuild53
-rw-r--r--dev-python/cheroot/files/6.5.4-fix-requirements.patch10
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 0fc46084f74c..2393705e10d4 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,4 +1,7 @@
+AUX 6.5.4-fix-requirements.patch 272 BLAKE2B 9694f577198f94ee1634468750f4ca8a1d66014fd8f3a65719d53bd27d99855a76478a5946e4a5c9f3515ad39be28bd12829f7672e83c7b887740ae0dd2e6418 SHA512 de0d3be2d062cb6a3088eb4e75f0ea97f57c81ee2d207acfb28780a757adddcd4e1e718ff6afe27cf98981db5d8347186ba74bd89a940f8b7ac406429a4759ad
DIST cheroot-6.0.0.tar.gz 62763 BLAKE2B 0946c01c6a6233dc60ca3dd896c3d1dbc0feb97d5099d88598db340a8812b2be4cb076383c0e39d30cd2c6fd3402e048b716a02e82bec8ce08d5b8fca4b1be0f SHA512 0109fbf3b73ed3f12261eaa3c6d86b6c6b80a1ba3564548ba3288aa6c61a1c08db60886e677991bf7997e6a5b1ec7767a3e06098ec1748453e72c40fda7b82a7
+DIST cheroot-6.5.4.tar.gz 81067 BLAKE2B 5304373bb8c7cefa341260d4fdb8a99b9e22041260342a716a6b95ba324b4f31d20fb44d8dc10840fb35d3b04de1283deb9aca11bc78772655bf7ad81cf16f3c SHA512 62a48ced225bf9167259b82f5e88a953bdc422982a6c0b0121b28e895cc8347cc033f573b57a048c59167586e0b21e94ad233ce2b65a1b72feb01db82b5ed411
EBUILD cheroot-6.0.0-r1.ebuild 925 BLAKE2B fc16e44b0f555c2e7e04ebdfa2fdfd9bd3f10f1e1efb23c38e5d8518da40db858d0c27d26126e70c51fd60143917c59fbe40fc45a0068a4aa1327706f79b63b9 SHA512 a8818fbc5af9b63e08a10b731cd11be8bae70282b2245677e3c96d4eeb4f90fb100f903267c33ddbcfb9c07da7631ce954bc84d74d1a33504a10c5ca53600d64
EBUILD cheroot-6.0.0.ebuild 931 BLAKE2B 53039d511b8884510ee22cb0f3cbf5c16bebcc2b1348deaa87af4b63cbeadd6f51e4110798c9669f286feef48b2bac678e2ca69cee6932f14d2561d655400c3a SHA512 5fe1f6b1eae632109fb51095a0e402acba031ab1ca90ace501d5da0b0ed3b86b6a2d6a7b80e6a776f27f28293f7538aaa3576aa40e683f74773bcb36d4ec0edb
+EBUILD cheroot-6.5.4.ebuild 1747 BLAKE2B 66e8a9a059db9cfc4069ac7723309d0a5ef78bfcf1c8d3a81544c6c53b6dbb9c766cd2deb4382b1a7cc45fd334a194cbb24666c8c65564a6682dfaa1a80e3884 SHA512 aa89e1dafa36acb417f9428a64a61ad24e6ee7bbb1e3b4d3cc2e10aa851a29df0e98b364afbbe66b56d554f39d5ad0969852b522e62a03c76bcd8683e7226eb0
MISC metadata.xml 370 BLAKE2B df7ec3eb606f1557e048245eca81402f40f9cd9bc4ec8112ecb0085f65530d9a66b952d56f826b2b97733018ec4b4d31c16ac26bebd3a40f3424421255fcb770 SHA512 22ff00c4677bd898e9d88f2bdebabed6a145a9dd33d6276e997c0435c64fc9dfd396a35a88c6facc8a3844187f0b598bfe8606637ea88420a6c33e1ea9765cbf
diff --git a/dev-python/cheroot/cheroot-6.5.4.ebuild b/dev-python/cheroot/cheroot-6.5.4.ebuild
new file mode 100644
index 000000000000..574f11ff4232
--- /dev/null
+++ b/dev-python/cheroot/cheroot-6.5.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="http://www.cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Unit tests are temporarily disabled for this version, see below for
+# what needs to be done.
+# IUSE="test"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]"
+
+ # Add the following for unit tests, some packages listed will need
+ # to be added and keyworded appropriately.
+# test? (
+# dev-python/ddt[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-sugar[${PYTHON_USEDEP}]
+# dev-python/pytest-testmon[${PYTHON_USEDEP}]
+# dev-python/pytest-watch[${PYTHON_USEDEP}]
+# dev-python/pytest-xdist[${PYTHON_USEDEP}]
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/codecov[${PYTHON_USEDEP}]
+# dev-python/pytest-cov[${PYTHON_USEDEP}]
+# dev-python/trustme[${PYTHON_USEDEP}]
+# dev-python/pyopenssl[${PYTHON_USEDEP}]
+# dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+# )"
+
+PATCHES=(
+ # https://github.com/CherryPy/cheroot/issues/181
+ "${FILESDIR}"/6.5.4-fix-requirements.patch
+)
+
+# python_test() {
+# py.test -v || die "tests failed under ${EPYTHON}"
+# }
diff --git a/dev-python/cheroot/files/6.5.4-fix-requirements.patch b/dev-python/cheroot/files/6.5.4-fix-requirements.patch
new file mode 100644
index 000000000000..a5a493704cfa
--- /dev/null
+++ b/dev-python/cheroot/files/6.5.4-fix-requirements.patch
@@ -0,0 +1,10 @@
+--- a/setup.cfg 2019-03-09 17:14:40.127863655 -0600
++++ b/setup.cfg 2019-03-09 17:15:22.135345396 -0600
+@@ -57,7 +57,6 @@
+ setuptools_scm>=1.15.0
+ setuptools_scm_git_archive>=1.0
+ install_requires =
+- backports.functools_lru_cache
+ six>=1.11.0
+ more_itertools>=2.6
+