summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /dev-python/cheroot
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest2
-rw-r--r--dev-python/cheroot/cheroot-10.0.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index d33f6c9108f7..3f0c6f7858be 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,3 +1,5 @@
+DIST cheroot-10.0.0.tar.gz 148461 BLAKE2B d6a07878b03529be0d7ebefc91096f89b437374f9ede1db357a286bc199403798d35e9695dc1251d5045b6febc37940986693d9b36c89968ac3147ec68a481ea SHA512 02e32e52a596463cbb9874a800dbcdc5680dd7d9dfa95ca6e73c81f9248a488087c514ae70cdba94fe9df1f5d3ab1c68efcb720561cbeb7b667109fe5962f85b
DIST cheroot-9.0.0.tar.gz 152562 BLAKE2B 5f5dd172cfc8fdd1318b22fc27060444a34343b6b83bbda4bd40c16d7cb0568c356f5fd14b0a7cdc74895d6707077ec54fcae54fb29b0d16a7c06e2cd36b1ee7 SHA512 86ea0dd2cb4cde25f86b489b1d0bb27e3e7c1ba5449759ccecaae689cdcb349b968fd0c8fb8bc8273deff5e32a078bf40f4342f0c5a1f53bb8d2b968f44a453b
+EBUILD cheroot-10.0.0.ebuild 1888 BLAKE2B 6e72df3e6f67b57dda5c0040fab84b802f0549582042aaa78d24d2bde19a8788669d46e3edfb9161f83b5cbeed6fa50bf8c7426ee982f2e842abc47ff696448b SHA512 72f976d0bdef1bb5cd9b3d7d28575bcca9fe4df613ce35782570998c91e007c825ca18204718a143d935890f62563736d7e450039d9840f9395e393c5dedb43a
EBUILD cheroot-9.0.0.ebuild 1924 BLAKE2B ecc24418c15d20bbcc2d78076dea44e5437bb94af84dc0b6913326fccb020d7537308baf0ecfb96a77a9c9973a4264cdf4f724657db9ef972ef3bb1238dbe4f4 SHA512 6b80c7d1e5513358638c7ccbeef0f7cbf0669d94069eb583e20039da5f255308207273439fc73cee0efca6a25ac627713d1f8bbe5cede26fc65c2dd9e3de581c
MISC metadata.xml 391 BLAKE2B 1c9c2af2c1a8bcd3f1c426a87d1a2a97fb88a9a30f9c2f1802b8885329277fcfde1deadf635e419cd7f85a5685639709be33aa746d9f7a04c3ac7d832d084b42 SHA512 c194e8bed8d082ed4ce3f2a7f608085fdcf2ab8b7c730e5c6ad7438cf177ed1892565cdff0feda564681f59bf6aefc327e3d24da0a543c0f043934af27873e95
diff --git a/dev-python/cheroot/cheroot-10.0.0.ebuild b/dev-python/cheroot/cheroot-10.0.0.ebuild
new file mode 100644
index 000000000000..8ecfaae8b79a
--- /dev/null
+++ b/dev-python/cheroot/cheroot-10.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
+HOMEPAGE="
+ https://cherrypy.dev/
+ https://pypi.org/project/cheroot/
+ https://github.com/cherrypy/cheroot/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' \
+ -e '/--testmon/d' \
+ -e '/--numproc/d' \
+ -i pytest.ini || die
+
+ # broken
+ sed -i -e '/False.*localhost/d' cheroot/test/test_ssl.py || die
+ # pypytools is py2 stuff
+ sed -i -e '/pypytools/d' cheroot/test/test_server.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pypytools, see above
+ cheroot/test/test_server.py::test_high_number_of_file_descriptors
+ )
+
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/pyopenssl[${PYTHON_USEDEP}]" ||
+ ! has_version "dev-python/trustme[${PYTHON_USEDEP}]"
+ then
+ EPYTEST_IGNORE+=(
+ cheroot/test/test_ssl.py
+ )
+ fi
+
+ epytest -p no:flaky
+}