summaryrefslogtreecommitdiff
path: root/dev-python/cli-ui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-31 01:33:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-03-31 01:33:08 +0100
commit033286afc1eb2e64a87a58798a0c620d8b56f497 (patch)
tree4793d794ccd00b0efa754d9fd07ad01694c17e0f /dev-python/cli-ui
parent5ddc3e2d8f01496ed8b9a87cbe9c939f8f317eff (diff)
gentoo auto-resync : 31:03:2025 - 01:33:08
Diffstat (limited to 'dev-python/cli-ui')
-rw-r--r--dev-python/cli-ui/Manifest4
-rw-r--r--dev-python/cli-ui/cli-ui-0.19.0.ebuild (renamed from dev-python/cli-ui/cli-ui-0.17.2.ebuild)16
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/cli-ui/Manifest b/dev-python/cli-ui/Manifest
index 44dc4d4534b8..01a3ed2788dc 100644
--- a/dev-python/cli-ui/Manifest
+++ b/dev-python/cli-ui/Manifest
@@ -1,5 +1,5 @@
-DIST cli-ui-0.17.2.tar.gz 13366 BLAKE2B b5dbccf136dad09bf213e199050c31cce545a44dd46b61f8eaad8b40679203da5b742a1deefc0f934bbbab286c101892d5b5e93c45624631f778245c4724ddcb SHA512 ea38c3c39b24f322b58f8e95e43609a22657018d36fd28d5dfa7887295eb4ad374032fdd2330762ed50826211ed11fa6a6356d93d09b2135264cf59f13749993
DIST cli_ui-0.18.0.tar.gz 13012 BLAKE2B c96eba706b5d7275c9ad76d1a099ff7bcda8ae894361ba8d0ac944531fe813d17156bb27cb6d342268fb28845aeedcef1d19c36f1ddda43d3b98cf46c30d9818 SHA512 69c68df27d74d167dc50088381a048265fc51603e7e13811895ac771df1cc03f9670274e73a162a67706afc9e2a4eb1ccd75872309a3c2c06f84c2ccaa03dd92
-EBUILD cli-ui-0.17.2.ebuild 737 BLAKE2B a992d84a028cb0da7e7c8a90b54731ad2551e377de43b41da8d395c470ff66ed9ddbea0a30d9885fb62abaf3274226bf8cbe7ddb55d374046a1e6efd4beb92c6 SHA512 4edd510ca5d151a074678b5e6cc482977673d7c4ead28baf4a8548de3eb331e2f65dcf0f7c175931bcd5eecd97811ec23cdb594fe4d7e1b86b1d24160f6f6197
+DIST cli_ui-0.19.0.tar.gz 12808 BLAKE2B 40e91549f407f77c69a7bb4ad8388b360b9b96c1629b7e45def8f93e8fb283a8c92d63ab1d68cbecd7a1bcb158a4cdc68ca8e48ac4d86f292f9db8df9991f126 SHA512 b8b4d917ecb95cff86cc088a8102e0bf7597a350e191f103c14e1357688911c1273d275f636f22e90980c9b9841cb2a47394add334652577053489159fec361c
EBUILD cli-ui-0.18.0.ebuild 776 BLAKE2B 6bba0128152e5436e11c9fd424ab83eba51c14b9ce6fa8a75422e01bc5ed5e78aba2ecb83a5b53b50955dc511dfb4b571a16ce65d284510c93e06ce54a356cfd SHA512 6082efa27ef0c63aeb06820a5924c38786bb7b1201b21596bb925d541c546685324643c92588d71ed182bbce73fbc87ba461d7427b0910bdbc819539be3273a3
+EBUILD cli-ui-0.19.0.ebuild 776 BLAKE2B fc13759f14dd0910ccb18cc204434d196e6b193ba70a964b84e60e74594a43f17faf7a6f0c609a547f64a02f87ef3b1e00df74dfc50d3ee2daf56a20a00ee205 SHA512 56afddd0b76e42622c8cda509837ae9349f2d5933459b55851f93f5aefda04c200573dbbc2e778a58b373e2eddd69596480c8ae6bb57694f2cb26177d3ebd3f8
MISC metadata.xml 572 BLAKE2B e4dda5027fb1278a406bf629f7968ba3d6d293d747149a910b6d17c9a84be76334fb1933c47c7c7ef08087f7834c5b77d888b081f1a74c432059f395c7acd16f SHA512 1b0e2ea706cb4a270d4b6fef10116237fd5ca3eb8fde1db5153abc047a231eca93e55049ae66443ca5901c86e9420384f3365e393077a88b000e5abf8f7581c7
diff --git a/dev-python/cli-ui/cli-ui-0.17.2.ebuild b/dev-python/cli-ui/cli-ui-0.19.0.ebuild
index be3d46adfd91..e61d04bb1683 100644
--- a/dev-python/cli-ui/cli-ui-0.17.2.ebuild
+++ b/dev-python/cli-ui/cli-ui-0.19.0.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517="poetry"
-PYPI_NO_NORMALIZE="1"
PYTHON_COMPAT=( python3_{11..13} )
inherit distutils-r1
DESCRIPTION="Python library for better command line interfaces"
-HOMEPAGE="https://your-tools.github.io/python-cli-ui/
- https://github.com/your-tools/python-cli-ui/"
+HOMEPAGE="
+ https://your-tools.github.io/python-cli-ui/
+ https://github.com/your-tools/python-cli-ui/
+ https://pypi.org/project/cli-ui/
+"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
@@ -27,9 +29,9 @@ LICENSE="BSD"
SLOT="0"
RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/tabulate[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-1.3.6[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest