summaryrefslogtreecommitdiff
path: root/dev-python/click-log
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/click-log
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/click-log')
-rw-r--r--dev-python/click-log/Manifest7
-rw-r--r--dev-python/click-log/click-log-0.1.8.ebuild26
-rw-r--r--dev-python/click-log/click-log-0.2.1.ebuild26
-rw-r--r--dev-python/click-log/click-log-0.3.2.ebuild26
-rw-r--r--dev-python/click-log/metadata.xml11
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/click-log/Manifest b/dev-python/click-log/Manifest
new file mode 100644
index 000000000000..0217f91bdde4
--- /dev/null
+++ b/dev-python/click-log/Manifest
@@ -0,0 +1,7 @@
+DIST click-log-0.1.8.tar.gz 9277 BLAKE2B 656088998bd6753f491e21a96dbd41e02e4decf1043217863478841b258b4d6e1c0ad7ffa983d0138ffccb22206b1f9fbe47ea0dbf305036db32d9810b149b5e SHA512 35baaabc54502f203da2fee02f6f63478f4f902bf333331b6ef9ae4b9d1677020ef0dce9f24f64e6e48bfc31280b72882f7cdf1f42ecf2cd941256d2e96a40e1
+DIST click-log-0.2.1.tar.gz 10062 BLAKE2B bc973ec0a7c9b98567b13bf22cb3732dc4ee9bcabee5cbb4942b9981e78893dc5ffef92142ef02d1d013fcaca81d28d5295ebd83a705adce189f7355fbbfdf7c SHA512 4fd56d4514fe3db74fd626c20579bb4bec559e60194d1b8127007281546e94b7b3248ede4da9f896fbf3e06be97db0ac9e7fe4cfd442848fe7b8e5392eced98f
+DIST click-log-0.3.2.tar.gz 9523 BLAKE2B 212ac421b402fc0f32a9aec11a9e20c87a8148c461af87af78f8068ca95d60cab0c47bf24162aefd1c299ba783fb7a70e7e9dde01f0fc1f7c44a69fa8cb07121 SHA512 8ae5c43d739127367bbcdcf32bfd4b34b2ea1c377948df3b8588e4bfe2b0f5e7a61d1ccc6cb32c77045b15251222866daffa5a7bfb7a907487548784ba345351
+EBUILD click-log-0.1.8.ebuild 627 BLAKE2B bcf03eabcb0f7efdeba93b163b074f4f5f864b5aaed5821f7239c2226b5e82f7e85240de64eff0d1b3c52d54cc67f48d91a7ddd124e80c9dd5826f0f22a5780e SHA512 68206b116b9c4c434e02ceddc58cbcf51f6156d9a956430a4ba0ae8320d17f93188caaf4baa682a7c477caaf3c77df9343e63b81adf030e6e0fa353a9f9a0503
+EBUILD click-log-0.2.1.ebuild 627 BLAKE2B 15e8a93d3ee244ae52e6981d1d27ab6e51a2d68334206675a7417c8685316b8e004dde932b2d132dfe265adbc6ac074e84b449406258e63ab890b7657c6dbddc SHA512 d0425254a5f5cb7ba97392f0e2528f46366e0110b4cee9c7cbc6d660ff3cce931f7ca6766086c0ac06f2dff50fd7c0972b2b234b8a00b667f16c6f24b418aa5f
+EBUILD click-log-0.3.2.ebuild 627 BLAKE2B 15e8a93d3ee244ae52e6981d1d27ab6e51a2d68334206675a7417c8685316b8e004dde932b2d132dfe265adbc6ac074e84b449406258e63ab890b7657c6dbddc SHA512 d0425254a5f5cb7ba97392f0e2528f46366e0110b4cee9c7cbc6d660ff3cce931f7ca6766086c0ac06f2dff50fd7c0972b2b234b8a00b667f16c6f24b418aa5f
+MISC metadata.xml 352 BLAKE2B da4fa1487d5ee53e0f682676dae2d9dbdb581ebe4289d2673ebfe4ab09759b6d7928c24b28cb4ade9a4d55e05c6473356590190327cced4f2b87b723d15d1c2c SHA512 20b7009e52be3fdfd67690972c9ad09d77a505a59bc2a4c65ede59a72e33e7ffeb7c6a663487e01c94aa73507ad5fe4154ee2f9e336c85d8e173c971644e77d4
diff --git a/dev-python/click-log/click-log-0.1.8.ebuild b/dev-python/click-log/click-log-0.1.8.ebuild
new file mode 100644
index 000000000000..d8718bfa82e2
--- /dev/null
+++ b/dev-python/click-log/click-log-0.1.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging integration for Click."
+HOMEPAGE="https://github.com/click-contrib/click-log https://pypi.org/project/click-log/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/click-log/click-log-0.2.1.ebuild b/dev-python/click-log/click-log-0.2.1.ebuild
new file mode 100644
index 000000000000..7f3e58c4a7b4
--- /dev/null
+++ b/dev-python/click-log/click-log-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging integration for Click."
+HOMEPAGE="https://github.com/click-contrib/click-log https://pypi.org/project/click-log/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/click-log/click-log-0.3.2.ebuild b/dev-python/click-log/click-log-0.3.2.ebuild
new file mode 100644
index 000000000000..7f3e58c4a7b4
--- /dev/null
+++ b/dev-python/click-log/click-log-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging integration for Click."
+HOMEPAGE="https://github.com/click-contrib/click-log https://pypi.org/project/click-log/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/click-log/metadata.xml b/dev-python/click-log/metadata.xml
new file mode 100644
index 000000000000..7e29ce9dfb6b
--- /dev/null
+++ b/dev-python/click-log/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amynka@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">click-contrib/click-log</remote-id>
+ <remote-id type="pypi">click-log</remote-id>
+ </upstream>
+</pkgmetadata>