summaryrefslogtreecommitdiff
path: root/dev-python/clientcookie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/clientcookie
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/clientcookie')
-rw-r--r--dev-python/clientcookie/Manifest3
-rw-r--r--dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild25
-rw-r--r--dev-python/clientcookie/metadata.xml21
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/clientcookie/Manifest b/dev-python/clientcookie/Manifest
new file mode 100644
index 000000000000..8827128a6dfc
--- /dev/null
+++ b/dev-python/clientcookie/Manifest
@@ -0,0 +1,3 @@
+DIST ClientCookie-1.3.0.tar.gz 130974 BLAKE2B 02b2e227078ee3fa01f377dbd96baaa15cc7f46ed4ac8f10d817b0da5e2b4bc090345f9057b946219907163cf230cc39213f6a92f4fee75d4dc2ba8ea57b3673 SHA512 3a42660557bbcda76f7e63fb4fea0ccaa15967e8e6991d65dc72921efb8cec475f7ebfbfe963e5577f7dfbacebb84488b7bb5e6e4e913e863e54c0faf0b4e9f5
+EBUILD clientcookie-1.3.0-r1.ebuild 651 BLAKE2B 039659be841d2cc2bbbb2ddfa0f343eaaab1bfa586a9eecda17f7d30fa90481afdc6c998e220e49346e2e900675e2b986e4e2847eaef9ead68b41f5ca07a24e5 SHA512 9164eee69f027fe723d1e8845862aa5b7da4b08f2cefc1c14710371813769c844d72944df194f0ed9f2a9375618378af83cf9bf2820874ef3275a848746437ed
+MISC metadata.xml 929 BLAKE2B 39902cc037ebd81f96e531d057dcbe942f1fd7c06174682ea0ede9af5cbf823145b7101699c354a4126404e63fcb98fa490449a88610d110b327814f7ebfb8e4 SHA512 3cfdde23672ae821a27cd5aa40597dd313ebdb915afae22f014e25f3fa86bda64330502cbe7a2535519b94bf60c1acc2a22d45529330517224fde6c9023f1a5f
diff --git a/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild b/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..026c593b482c
--- /dev/null
+++ b/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="ClientCookie-${PV}"
+
+DESCRIPTION="Python module for handling HTTP cookies on the client side"
+HOMEPAGE="http://wwwsearch.sourceforge.net/ClientCookie/ https://pypi.org/project/ClientCookie/"
+SRC_URI="http://wwwsearch.sourceforge.net/ClientCookie/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="*.txt"
diff --git a/dev-python/clientcookie/metadata.xml b/dev-python/clientcookie/metadata.xml
new file mode 100644
index 000000000000..76ae290ba533
--- /dev/null
+++ b/dev-python/clientcookie/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ClientCookie is a Python module for handling HTTP cookies on the client
+side, useful for accessing web sites that require cookies to be set and
+then returned later. It also provides some other (optional) useful stuff:
+HTTP-EQUIV and Refresh handling, automatic adding of the Referer [sic]
+header, automatic observance of robots.txt and lazily-seek()able responses.
+These extras are implemented using an extension that makes it easier to add
+new functionality to urllib2. It has developed from a port of Gisle Aas'
+Perl module HTTP::Cookies, from the libwww-perl library.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wwwsearch</remote-id>
+ </upstream>
+</pkgmetadata>