summaryrefslogtreecommitdiff
path: root/dev-python/cliff/cliff-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/cliff/cliff-3.4.0.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/cliff/cliff-3.4.0.ebuild')
-rw-r--r--dev-python/cliff/cliff-3.4.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/cliff/cliff-3.4.0.ebuild b/dev-python/cliff/cliff-3.4.0.ebuild
index 97560bbb48ee..2cb3eca1cbe9 100644
--- a/dev-python/cliff/cliff-3.4.0.ebuild
+++ b/dev-python/cliff/cliff-3.4.0.ebuild
@@ -4,7 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+# pkg_resources is used even though the QA check doesn't detect it
+DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -20,12 +21,15 @@ RDEPEND="
>=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
<dev-python/prettytable-0.8[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
"
-BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]