summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-23 05:40:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-23 05:40:46 +0000
commit914bc7f07098ac3918913e4c83951a9cbba5a949 (patch)
treec0b60465fdd9785c668cc6698835d92b226c1d7e /dev-python/cliff
parent1e153f5e3ce504af9cf586c9b819e4f0bc919f3b (diff)
gentoo auto-resync : 23:02:2024 - 05:40:46
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-4.6.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 1291ded17217..987fbb03e392 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
DIST cliff-4.5.0.tar.gz 83722 BLAKE2B a610c65250cdf1ed33910408bdcde64a308c931d9e2c4d34d4b1b6e1c801354bf76833997b1672bf8b3cee54323da02baae479bf721a5ed507cfbc267c8c978d SHA512 e32f5c6f53a37306e79de79d3be653ea9fbe8581da6162578048f17188bb48d82a8108bd118cf34712601b08f53be80287c33929e07993c7363b09ad4f076d33
+DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
EBUILD cliff-4.5.0.ebuild 1065 BLAKE2B 833fd77b9182136db5eb12394a1bbb440e15765fad3a732fbd53dc321cf6bc84c3a70ef46ff242233cf3d79ec1eb69dac1f073097b6c609d7e5ac1f61615ba18 SHA512 a27e2fc82b382af5350fe9562eb3e1c46d6f4a8f4b9e45851dead3692965f11f737e069e7d06dad5800f77b44f15552df84bd437010d990169e87904766d899a
+EBUILD cliff-4.6.0.ebuild 1069 BLAKE2B 9aea77cc97cd98ecdd1324e061884d7ddc558ff6673fa6855a0817f74d5230b4c58823071feaf6e53785e0c26b620762bb0a045e1136d9a56cdd25c43a558782 SHA512 811a21488c78f8d720db4f72b9ee39ef403ad349247e8d4ca96f6250ac5a427ed52becaf8ac20981dd1e1df8b53f372daf641fdc185414f5aebb1fabb45790bb
MISC metadata.xml 712 BLAKE2B 367482d2ee04af7b55c217aaa49b5784333f66b1a25dffc0bcf5b639c90d69df0002feac780e36ca7a7c40fd40be424c8116389fbaf9ad5547ffb7f2f5f34697 SHA512 dfcdcdb8f473a5f9caaf281f3c408b21c15dee411c71f45ac0c2f79d2ce2ab5aa29bc59d5fcb1ee13db033509b38c27a3b9d5c07b6bd20a10e9933632f9f5657
diff --git a/dev-python/cliff/cliff-4.6.0.ebuild b/dev-python/cliff/cliff-4.6.0.ebuild
new file mode 100644
index 000000000000..285b66c49d90
--- /dev/null
+++ b/dev-python/cliff/cliff-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest