summaryrefslogtreecommitdiff
path: root/dev-python/codetools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/codetools
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/codetools')
-rw-r--r--dev-python/codetools/Manifest5
-rw-r--r--dev-python/codetools/codetools-4.2.0.ebuild35
-rw-r--r--dev-python/codetools/metadata.xml25
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/codetools/Manifest b/dev-python/codetools/Manifest
new file mode 100644
index 000000000000..59d476bd6bea
--- /dev/null
+++ b/dev-python/codetools/Manifest
@@ -0,0 +1,5 @@
+DIST codetools-4.2.0.tar.gz 117891 SHA256 a93452b3f421bb5f9f18a74d404661433e189e29de3a4b9cfe92544e69be9c2c SHA512 8b63b9cb65966db72f3d2b054559fadf3008a4f4a7fc66ff12b046ca18568694c9d11066d6450e38b053b73df31c8a136729d7052bf8e21f287eac220ddf5dbb WHIRLPOOL adf4f8f3a516cf14cb8c71a4874b80c09814b017872be5dbb7768e506fecfc76d59805763d1cf3dbfdf941f86efd3893545e314932bad93c461a4468cee5c15e
+EBUILD codetools-4.2.0.ebuild 884 SHA256 cef4204e6dd94ed12cf9140f8f3507fa790edbdf692156959148361a4a00686a SHA512 8dc27482d89ebeb4e8c038e04dac0b0c7cdd5389010fdc96d1464a3936074f050fb5590cca91953e77dddeeadbda3e2fc9a44125539acc375b649f4bc06ba857 WHIRLPOOL 37f98d480213298a39797b1b07011347f2583048c20a3a4e2ba6cdcf49eaf04b968e04511797fbdb1aae81a601cd15dabba1d657994cc215fab8ec1efbaef695
+MISC ChangeLog 2435 SHA256 8f4b5b7323e3e86ffc2a9e3ff4a5be95546b9912705a89c17315e95c924b4c65 SHA512 e44c59a512b6965a40213e4310784bce9b845bd27c0dfdef9d107ade3630a9f1536852020d5a0776d689ff8107573c6521c7bd85b47abeb1abd0062b5ef78f69 WHIRLPOOL 260657e6a635421c4ffca3f8927738379ba2820c62767e037920d13879f6e3a5289f83f3a893c9ad470848618ae87c3f265194fb09f48fc90fdb6fde07ee457b
+MISC ChangeLog-2015 2881 SHA256 6cf806648dbfc08b0d2233dcad94ebd7446133da891d87287d5a5c48e19d4760 SHA512 7f3f8c51b9e237d67ade01cc5d19970a81d1700e74133bd916d7983294bf45da0a6ea3962fd2ee1fd44990435945f510174a7524297fa6f3ff4eac27520abc5c WHIRLPOOL 651d21a8af3965ce86ef7093cdc3c442bf437cf998e45bfbdf02cb17dc765e3043d9cd2638cb65a4ba1495d00fb684058509462f2d49939a4e00dea1dd7d19f2
+MISC metadata.xml 1134 SHA256 0760803d0d877ea19e643f08e8ef54cb3b946fb60067d3c2b95a438286d4fc4c SHA512 764080f26934d139d4fbb11a55c40d4342d1fe2132b4291dfe5fb0f558ca3ed26f3e61d335b343c4edd8812bafbb084098f5f0622cd78af785a21f6f6b4c668c WHIRLPOOL 9623652f4eebec688de5c6979d07c75fedbca2573205436387d449d344cb5e8d98c871e7052008dd846af16859e42d6d133a61ffc9769ac7671b5c008a70777a
diff --git a/dev-python/codetools/codetools-4.2.0.ebuild b/dev-python/codetools/codetools-4.2.0.ebuild
new file mode 100644
index 000000000000..cf645d00d48c
--- /dev/null
+++ b/dev-python/codetools/codetools-4.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Code analysis and execution tools"
+HOMEPAGE="http://code.enthought.com/projects/code_tools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scimath-4[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/blockcanvas[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake -e with_mask_test_case
+}
diff --git a/dev-python/codetools/metadata.xml b/dev-python/codetools/metadata.xml
new file mode 100644
index 000000000000..50a6152a5ba7
--- /dev/null
+++ b/dev-python/codetools/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<longdescription lang="en">
+ The CodeTools project from the Enthought Tool Suite
+ includes packages that simplify meta-programming
+ and help the programmer separate data from code in Python. This
+ library contains classes that allow defining simple snippets, or
+ "blocks", of Python code, analyze variable dependencies in the code
+ block, and use these dependencies to construct or restrict an
+ execution graph. These (restricted) code blocks can then be executed
+ in any namespace. However, this project also provides a
+ Traits-event-enhanced namespace, called a "context", which can be used
+ in place of a vanilla namespace to allow actions to be performed
+ whenever variables are assigned or retrieved from the namespace. This
+ project is used as the foundation for the BlockCanvas project.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">codetools</remote-id>
+</upstream>
+</pkgmetadata>