summaryrefslogtreecommitdiff
path: root/dev-python/codetools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/codetools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/codetools')
-rw-r--r--dev-python/codetools/Manifest3
-rw-r--r--dev-python/codetools/codetools-4.2.0.ebuild37
-rw-r--r--dev-python/codetools/metadata.xml22
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/codetools/Manifest b/dev-python/codetools/Manifest
new file mode 100644
index 000000000000..e6e08523bbfc
--- /dev/null
+++ b/dev-python/codetools/Manifest
@@ -0,0 +1,3 @@
+DIST codetools-4.2.0.tar.gz 117891 BLAKE2B 970d56037fdad518aa8975805a70238aa417a74649fa94c8383e2828447860b7a4d9467c54adf7f519e0f07e8852f0639486c1d3b5f80ccc6afc0d0d18da7d8a SHA512 8b63b9cb65966db72f3d2b054559fadf3008a4f4a7fc66ff12b046ca18568694c9d11066d6450e38b053b73df31c8a136729d7052bf8e21f287eac220ddf5dbb
+EBUILD codetools-4.2.0.ebuild 951 BLAKE2B de5a3742e7b0964d831bce313ed164fd320e2f51c7c3cd5328574f50f0c18296f563da6cc583b8a9a802984942ceeb8bb3d279d1cd5b7e16c37594ef92b428be SHA512 8ea205d5df6fff1da8f59c9eebc5b7fa933e8e79d8bbf01c3a6d47adf4f940f45ac13b9aa2f6d7b021275bb7419019bd883013f5023855fcb49b9af6bbed3784
+MISC metadata.xml 1062 BLAKE2B da2bc689fb8e5d946c7130980d9cc3c2805f6d364a2ce409c6ee236b2f4a208bd1094ef7e4de7b3b32577631ded69bda551d6d1a965d420e320763969006df7a SHA512 a260490ca42b7d23c89519b9f0f78c6a91baa94e03292873888d806d28237c0ea6eb28564b55f464fb4f39b7407a9658c9585cd477bc01e7b526ec1aedc0479a
diff --git a/dev-python/codetools/codetools-4.2.0.ebuild b/dev-python/codetools/codetools-4.2.0.ebuild
new file mode 100644
index 000000000000..fe151340e438
--- /dev/null
+++ b/dev-python/codetools/codetools-4.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Code analysis and execution tools"
+HOMEPAGE="http://docs.enthought.com/codetools/
+ https://github.com/enthought/codetools
+ https://pypi.org/project/codetools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scimath-4[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/blockcanvas[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake -e with_mask_test_case
+}
diff --git a/dev-python/codetools/metadata.xml b/dev-python/codetools/metadata.xml
new file mode 100644
index 000000000000..88fb0b2e0e85
--- /dev/null
+++ b/dev-python/codetools/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription lang="en">
+ The CodeTools project from the Enthought Tool Suite
+ includes packages that simplify meta-programming
+ and help the programmer separate data from code in Python. This
+ library contains classes that allow defining simple snippets, or
+ "blocks", of Python code, analyze variable dependencies in the code
+ block, and use these dependencies to construct or restrict an
+ execution graph. These (restricted) code blocks can then be executed
+ in any namespace. However, this project also provides a
+ Traits-event-enhanced namespace, called a "context", which can be used
+ in place of a vanilla namespace to allow actions to be performed
+ whenever variables are assigned or retrieved from the namespace. This
+ project is used as the foundation for the BlockCanvas project.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">codetools</remote-id>
+</upstream>
+</pkgmetadata>