summaryrefslogtreecommitdiff
path: root/dev-python/configshell-fb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-12 12:31:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-12 12:31:24 +0100
commit3ea54510168a7ed4271b85f7292beca67346bfe9 (patch)
tree560f44ef2b85e5594b847ab20454e58b35ecd7e2 /dev-python/configshell-fb
parent65a36438d5b824f80023c282dadc3fcd5736b526 (diff)
gentoo auto-resync : 12:09:2024 - 12:31:23
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest2
-rw-r--r--dev-python/configshell-fb/configshell-fb-2.0.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 1001bdb472eb..f0fb6c7d0396 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1,3 +1,5 @@
DIST configshell-fb-1.1.30.gh.tar.gz 33179 BLAKE2B 8664ec42727fb9bd41600c2844b9b59423c21040e6efc201f40b54abf6d788fa5237d38e2795d0d19706303d99e7ea859b399fd5f122cb04effc643a33b264ac SHA512 b3189130ac047fe28ea987391591b7886f7234864d455a8423d1d65b02a514511e2a32dce1429a6b71cedbc0b7cb6e6e10f29d240b746d222c285f0baa6b46b0
+DIST configshell_fb-2.0.0.tar.gz 33794 BLAKE2B 7bb46a19b58107c7e4d0f7a4dde9520cdd31b85238ad7579f85c30f855c7fb90736470419e7f6882bbeed89d9d55091b92f7a3f1e4bbff5e5a9eae813c148756 SHA512 3e0c0c3fda661cd09d80cd07e32cc942aa804fde49c00cfed5234671b1005f8126264c39a72aec466b3b9324366faa83828eee74f8b541d6f8bc628548d31a9e
EBUILD configshell-fb-1.1.30.ebuild 801 BLAKE2B c6cf3108b166b2652e4680172227235cdbc6b901c190d06b54e18fc665420acdf6582e72a22c34ee2070868a6e79fc76c67d20913faaa373ea15cad6bd3ac4ab SHA512 21c9025e22c9bdc15e481c47fe1d2eedbed85fc98584c5a186c7712b0162e4468fa84239006d73d83c0aca6d4091d7e1edd7e300e721966a1544907267de20fa
+EBUILD configshell-fb-2.0.0.ebuild 692 BLAKE2B 9c08fccd5de774abff7cfd13bc87d6f94eec1623bc2bf5bfb8a5a7d02b1f9912b403d369f2aed6e7cf5b49461d2605693af90533e8d6bf7e3f22cb4e08aa34cd SHA512 4c00668574f2c898aa7ab7a30d79ed70a3aef4a0e74a6ccad4fccbba864cea9ea5544ec66ca0f007f7071531916bb9da2f7c108234f9044a6e2958d4d1190745
MISC metadata.xml 789 BLAKE2B fc1e6e767a4b869c7cfade0a030133a746acdea98b9991740eb82a74f82eb29d495807682a1d521667162ba39a68c966c78ff1e39338d1273d173915e6401a61 SHA512 76a628ddb64f2ce5e0fa09faef29cb7b643e03cee337b9b3554d3a6ac3873be64b8fc66067c93087938e71473f0e2ae3af0a50f0a3b19195b87d69680ded5cd8
diff --git a/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild b/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild
new file mode 100644
index 000000000000..dc77fba66ca9
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}