summaryrefslogtreecommitdiff
path: root/dev-python/configshell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/configshell
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/configshell')
-rw-r--r--dev-python/configshell/Manifest4
-rw-r--r--dev-python/configshell/configshell-1.6.ebuild29
-rw-r--r--dev-python/configshell/configshell-9999.ebuild29
-rw-r--r--dev-python/configshell/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/configshell/Manifest b/dev-python/configshell/Manifest
new file mode 100644
index 000000000000..93efef38a5e2
--- /dev/null
+++ b/dev-python/configshell/Manifest
@@ -0,0 +1,4 @@
+DIST configshell-1.6.tar.gz 37246 BLAKE2B f46be92f945d06583a02ac2aa4dba7bc1a91b888faf2235222b4c3975eaffee26a487f809c94e232540266ed78bf55c44e7e364d719c8ab08e11ac52d4674afe SHA512 04eeabfbe36f8845eb21cfe2b41a6a82d029ca23fe821ecfbf94d321fb8c9cc20f3d374b385cb20e00fd34a59feb364400d724e973174d9be90dad35813da0e0
+EBUILD configshell-1.6.ebuild 688 BLAKE2B 6c2286416e57a97b68a09ec653dd94f8ffc0b52e8822b5624ec6f036c186fab77bddbcf273f2aa1bc176020a5b656c9daf291929e8eac4481637a64230776a0c SHA512 9c2075738ce0edeac353a1e6ca02b7dd8762ae6b8c17e9c4f3c99691789a5d0fec7ad218581044ff86127cb20fc6d68a0dc6ab02751991464dc791df3c2557e5
+EBUILD configshell-9999.ebuild 688 BLAKE2B 6c2286416e57a97b68a09ec653dd94f8ffc0b52e8822b5624ec6f036c186fab77bddbcf273f2aa1bc176020a5b656c9daf291929e8eac4481637a64230776a0c SHA512 9c2075738ce0edeac353a1e6ca02b7dd8762ae6b8c17e9c4f3c99691789a5d0fec7ad218581044ff86127cb20fc6d68a0dc6ab02751991464dc791df3c2557e5
+MISC metadata.xml 340 BLAKE2B 921080fe3fd820019e2dc3c9f75dca364670952781570f838b96d66dc74992d6446629e3d1601595d69b721881464cac2dff6a2e662c984bc6b60fe431522dde SHA512 cd22fb2356a647fbb63189446497d03dc3f39c6d657bb91ee9c74d3c3c5db97136e280460a9dd8b8694489514e66585a01cfea73984aa24dd66bd1139cdb3f27
diff --git a/dev-python/configshell/configshell-1.6.ebuild b/dev-python/configshell/configshell-1.6.ebuild
new file mode 100644
index 000000000000..01c369dd1a66
--- /dev/null
+++ b/dev-python/configshell/configshell-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="ConfigShell Community Edition for target_core_mod/ConfigFS"
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/urwid[${PYTHON_USEDEP}]"
diff --git a/dev-python/configshell/configshell-9999.ebuild b/dev-python/configshell/configshell-9999.ebuild
new file mode 100644
index 000000000000..01c369dd1a66
--- /dev/null
+++ b/dev-python/configshell/configshell-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="ConfigShell Community Edition for target_core_mod/ConfigFS"
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/urwid[${PYTHON_USEDEP}]"
diff --git a/dev-python/configshell/metadata.xml b/dev-python/configshell/metadata.xml
new file mode 100644
index 000000000000..c6e531475cdd
--- /dev/null
+++ b/dev-python/configshell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Datera/configshell</remote-id>
+ </upstream>
+</pkgmetadata>