summaryrefslogtreecommitdiff
path: root/dev-python/cov-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/cov-core
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/cov-core')
-rw-r--r--dev-python/cov-core/Manifest1
-rw-r--r--dev-python/cov-core/cov-core-1.15.0-r3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cov-core/Manifest b/dev-python/cov-core/Manifest
index ead5923ad6ef..2689034de1ef 100644
--- a/dev-python/cov-core/Manifest
+++ b/dev-python/cov-core/Manifest
@@ -1,3 +1,4 @@
DIST cov-core-1.15.0.tar.gz 5890 BLAKE2B bddab94ae47ba19ecdee5aae0198d9086a423673362ac64f0885f773bd8b8ab3f4d6abf1203ee901e272161dfb4b64168f2aa5f2d0f4426ea279d6d7251e921e SHA512 1b962a6a7253c1f6530248f3a71058e7709ee5cca274166807f040163c9cc240e9e85e42820063476c1c0f6dfca81d45277738663ed818fe715b30db151ace16
EBUILD cov-core-1.15.0-r2.ebuild 528 BLAKE2B e33315012368b053d1dbbeb4bcb4836af4e710afbb169e4bdd5914827e7871e7fe2b7d0836fc0c240d06bc8161861fd86b4313c601f5fbb56e5f3e65723eb697 SHA512 aced872a03cddb1e057e0238a3b0c986457295cee78ef552c1b65fea5f17adbcac19e0904d775d8c2b881db5f2057b6d68171a3193ae0eb747a31dfe0e65744b
+EBUILD cov-core-1.15.0-r3.ebuild 770 BLAKE2B a0d006aa5d535506b6312eba3e42b8ae4dd8e69093d3dc2fc2402c535ec6ac954d78ae2fedb75335ab0c8fd0541fc847face5a9c5b015a762bd6b52d523acbb6 SHA512 6dfa7103fb8af3c79c807c92d1ad8d8dbfa6ae0a5a6346bc0d0fc78e0dd47941268cf397a1d56328638101751449421dcfb23c7b52e8882d72c0a31ffc636965
MISC metadata.xml 390 BLAKE2B aab827988dd06e159c90e046b5512e3f8c0e5a2fc4ebc151753d6275bcb61f152a27dd77140bca513a45dd99292faf177c57d84bd414fde2cabcbc42d00ce8f3 SHA512 e323cc6408f939b8f49d2ad24f56b96dcf08c01a27cf6aa8e636fe913aa7adfd38de727ea337a1c9498062afb6f5c8d1a5f4cd2d78aec41d14ccb167b8ad41db
diff --git a/dev-python/cov-core/cov-core-1.15.0-r3.ebuild b/dev-python/cov-core/cov-core-1.15.0-r3.ebuild
new file mode 100644
index 000000000000..932a3334d2b7
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://github.com/schlamar/cov-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+
+python_install() {
+ [[ ${EPYTHON} == pypy* ]] && addpredict "$(python_get_sitedir)/init_cov_core.pth"
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}