summaryrefslogtreecommitdiff
path: root/dev-python/crcmod/crcmod-1.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/crcmod/crcmod-1.7-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/crcmod/crcmod-1.7-r2.ebuild')
-rw-r--r--dev-python/crcmod/crcmod-1.7-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/crcmod/crcmod-1.7-r2.ebuild b/dev-python/crcmod/crcmod-1.7-r2.ebuild
new file mode 100644
index 000000000000..66b1a3f2c5e3
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DOCS=( changelog test/examples.py )
+
+python_test() {
+ "${PYTHON}" test/test_crcmod.py || die "Tests fail with ${EPYTHON}"
+}