summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
commit325837835fc86686829aaa6acace3d3c06c74cea (patch)
tree6cc31680e4ce26ab26e863fd7b72d0ffe2d9366f /dev-python/crispy-bootstrap5
parent7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (diff)
gentoo auto-resync : 08:10:2024 - 04:26:34
Diffstat (limited to 'dev-python/crispy-bootstrap5')
-rw-r--r--dev-python/crispy-bootstrap5/Manifest2
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.10.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap5/Manifest b/dev-python/crispy-bootstrap5/Manifest
index 98cf470bb93d..0fe1bcaee30c 100644
--- a/dev-python/crispy-bootstrap5/Manifest
+++ b/dev-python/crispy-bootstrap5/Manifest
@@ -1,3 +1,5 @@
+DIST crispy-bootstrap5-2024.10.gh.tar.gz 34186 BLAKE2B 3a005b5b344b3d41692242e0bb69cc42bc10d73ae9d90d74c23d47880939e8fa71280140f053afa919902d7a54dfe7703041f1c6033207b05b776072009cd01e SHA512 84a99877ee0695aaeea70f76fd48c4fab062320cdd82aaa663effb6f311ba7f823de8df6e576b0301afcb6a8241bfdbbacfda12fbffdeb95ac7a16c3f6f95b9e
DIST crispy-bootstrap5-2024.2.gh.tar.gz 33509 BLAKE2B 4a1eec0cea4ee2b0fcbdd8aec6b4595a7b981b0502113d5154585702cc20d9c80cf28fd06db8085dd561c154e13fa493ee88bc3a9c0e619684ab56fce1376d70 SHA512 08c0e35caff14c53976283a383da5a8115a64b42a5a0797089c2528f3e2c0e03eb0826f48c1991bdbbd183afc486c0a238c73e782a76eac1d003e5760ddd852e
+EBUILD crispy-bootstrap5-2024.10.ebuild 753 BLAKE2B 74d0df2de6135b1e7116964cd83a59201efec1a4ccea6aea8df8bd331b906a489d8e32dcca99d74c644caceaffc36bc8e681f362d90a42fbed3b05bf79bf40a7 SHA512 51541021fd1f11193e4418d5bd4d6fdb2739c21abd5f66696ab7ab3b49a45908a0f5a823bdf4ba8e580fcfa1ea65a4b7f3faaac051e3a55c7d94b5caabdd3763
EBUILD crispy-bootstrap5-2024.2.ebuild 751 BLAKE2B eb5efc57a17f74875766187ebd8aa52ebf3656bbf02b801817e512a1b866585de6672298b7e2b1569f9f731967cc411f4b212fbdb3dde05f5940526266e7cfae SHA512 2e05318992c342b3ff31a9e4e6e8aa572737ef1d49a4e9c22e8db5fabc74fe178cb302a7651bfa84676ea424d2709a44ee2b44cef4a09182963db02e9b0acbe5
MISC metadata.xml 405 BLAKE2B 4b4a3bf239037510067beb822fe736db7235f0f530504831e7e64b70b311f34d52e842b19b155ba3bad6d607b25cbda34d926bd6691da2316551f3d86b11c94e SHA512 4c44e8ae1e2729af4c84217f287316e1aa098b80c62770d77cf690bc8c34f6df03f0aed2ef4c5ef22e423270abf737058f48f64b78d7b2b882b151992b0701a8
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.10.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.10.ebuild
new file mode 100644
index 000000000000..50a81348a268
--- /dev/null
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
+ https://pypi.org/project/crispy-bootstrap5/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest