summaryrefslogtreecommitdiff
path: root/dev-python/css-parser/css-parser-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
commit940cec7afea0fff03b206c62a512335e6f9d2d00 (patch)
tree719c138f497dce562bd86f32bec882f5a4220459 /dev-python/css-parser/css-parser-1.0.10.ebuild
parent752353adf60f88b9de2c3c752a871b9f907e2acb (diff)
gentoo auto-resync : 22:10:2023 - 08:45:32
Diffstat (limited to 'dev-python/css-parser/css-parser-1.0.10.ebuild')
-rw-r--r--dev-python/css-parser/css-parser-1.0.10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/css-parser/css-parser-1.0.10.ebuild b/dev-python/css-parser/css-parser-1.0.10.ebuild
new file mode 100644
index 000000000000..2473bba51393
--- /dev/null
+++ b/dev-python/css-parser/css-parser-1.0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CSS Cascading Style Sheets library (fork of cssutils)"
+HOMEPAGE="
+ https://github.com/ebook-utils/css-parser/
+ https://pypi.org/project/css-parser/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest