summaryrefslogtreecommitdiff
path: root/dev-python/cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
commit6d730aa8064fbab6cc54447b6ed0e60b99c13256 (patch)
tree8c303cb48dc49dd218b79708ca71904653c5f831 /dev-python/cstruct
parentcb2f73d10494730ba590096a1f24ebc6d0d61a9f (diff)
gentoo auto-resync : 17:01:2025 - 06:41:55
Diffstat (limited to 'dev-python/cstruct')
-rw-r--r--dev-python/cstruct/Manifest2
-rw-r--r--dev-python/cstruct/cstruct-6.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/cstruct/Manifest b/dev-python/cstruct/Manifest
index 82b641d94ee7..68318051f2d4 100644
--- a/dev-python/cstruct/Manifest
+++ b/dev-python/cstruct/Manifest
@@ -1,3 +1,5 @@
DIST python-cstruct-5.3.gh.tar.gz 38987 BLAKE2B 49fc1d7bc70faa1b437a82e22c5e187800dbaacd152685eae2defe3c6cf748ebe73910cf43066661b9f456261619a59c1ac546dc8ddc461bd1967bee6ffe7672 SHA512 71ad411c6733676c165c9724554a7c1b5f56921ac925020817d812b53b1dfcc9a30d794e8aa8da75bae144e3d659a7426034b5cced4262a699e4626e287b3790
+DIST python-cstruct-6.0.gh.tar.gz 40316 BLAKE2B 7dfc5c7515c08f18795dba886cfec64c4a86780b721738bd0377c85d62543bcb8ebdb854c4b1a24d0972f73435b92deb3ca6bbbf6324352d6f34ff582775477c SHA512 77ca6876cfc68e0c27a84eebcf3a356d3a9241cb68b7e912dbd9db29d17f074f115d983de6216a068d754506f301616ed0e7e9284023f7a27304e787beb7a547
EBUILD cstruct-5.3.ebuild 585 BLAKE2B d592c189d05b95d63fd3cea28c30c79ac6027f712ad5ec7a4f66b6c01092d40e225b921128e428ed25ddf48e2212999b464c63c579c34e86641e045f5e3a3857 SHA512 cb5ea2b3e3a70ad3cead4d1cbd0dc6fa25fea2b969781677a3d7bb4bd69f2ece63d83ce15ee8f9af528912889054be59a5c2c96dbe6bd2c90788bace5fd6915c
+EBUILD cstruct-6.0.ebuild 585 BLAKE2B b0cbb25d1a426cb79ddb78cd6430cf5b2b81b6d2e566649fdf6d1b62b7ba81ab88d4a409716c3ec25ebc752cc024b4543aaca90f6639ee0be412c06916920a9d SHA512 57cb38ebffb6ceba778b621e2400eb50f99a485babd7c31352b345b3fe7f7ea1ada74d4578fee2918ed77e9abea6a070e556abe9a2a15ee469bea888707a0166
MISC metadata.xml 454 BLAKE2B 5138bc275b0b9e18cab52fb309283c6b6dab8be5dcc3c86dd6526f350b216c68bc94dd2aabc7a33a4879c23165924563396c6d5991f5c702a12e184067d25cdb SHA512 bb259a25444029d8ea63577f0576ab283282298d27987e276bf4eb6d4ef00853ed019ad199830e9bb4e738f9a151feb55d53e76917508f1033c2b3ecd246276f
diff --git a/dev-python/cstruct/cstruct-6.0.ebuild b/dev-python/cstruct/cstruct-6.0.ebuild
new file mode 100644
index 000000000000..e806b1f1dae3
--- /dev/null
+++ b/dev-python/cstruct/cstruct-6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-cstruct-${PV}
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/python-cstruct/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest