summaryrefslogtreecommitdiff
path: root/dev-python/cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
commitc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (patch)
tree56249d49d47e3dde9d3298ed175d983defedf23b /dev-python/cstruct
parent6790f1eddc7029fda1a6bae94751a4ff1eb57776 (diff)
gentoo auto-resync : 09:01:2024 - 13:01:22
Diffstat (limited to 'dev-python/cstruct')
-rw-r--r--dev-python/cstruct/Manifest2
-rw-r--r--dev-python/cstruct/cstruct-5.3.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/cstruct/Manifest b/dev-python/cstruct/Manifest
index a25c0b8ee46e..f493caff6ae7 100644
--- a/dev-python/cstruct/Manifest
+++ b/dev-python/cstruct/Manifest
@@ -1,3 +1,5 @@
DIST python-cstruct-5.2.gh.tar.gz 38551 BLAKE2B d366c7508c33f7dd492cb3a507a358129159634b9f32293c4a06a8c1a24e9d4ae5e6a1fd89144907497e17b2558277fe98d4a5d92313402304bb18bec5c395ea SHA512 d9a961270e4769d1133a459f952f22b42733421436c53ac9bfc8159330503af1a2231c99afb2e91863ee8ad4d822a0d84fc6db6aac11b5358bca5548f0006e3e
+DIST python-cstruct-5.3.gh.tar.gz 38987 BLAKE2B 49fc1d7bc70faa1b437a82e22c5e187800dbaacd152685eae2defe3c6cf748ebe73910cf43066661b9f456261619a59c1ac546dc8ddc461bd1967bee6ffe7672 SHA512 71ad411c6733676c165c9724554a7c1b5f56921ac925020817d812b53b1dfcc9a30d794e8aa8da75bae144e3d659a7426034b5cced4262a699e4626e287b3790
EBUILD cstruct-5.2.ebuild 585 BLAKE2B 26f2f70fe8eeccf83c219d3beb6894c0e227f6cfd14bfc9dfde90195c5ffdec3d9d07bf63edfce5d7c4a069b51d82b80dab42f1fe82e1d27230259dce4efdc1d SHA512 4eec68dbcb61820652768ceaf308065502f34f3987e258b06d3c596a917187b1ab80b47e8cdb91c5a36b85e41e8750e7862d47bfb540f0d22f67252f5857ebbd
+EBUILD cstruct-5.3.ebuild 585 BLAKE2B da0de8f7fb6e17efa99427d0c38be4de4fb0dc2d4091ba1fa57b1409fb88c5fcb157d8489c0c99123af41480b5dd4c013a0d5f6870033ce1c5b64c1475ef9a6a SHA512 7516f8930cbbe09316d7da7e709d57c1e88d0a120fb3e755511b9e643552a0e456eca363f6059a3132d08ea6d9adf5dc86b8f40abd6f75dcf34844fe1d802a51
MISC metadata.xml 454 BLAKE2B 5138bc275b0b9e18cab52fb309283c6b6dab8be5dcc3c86dd6526f350b216c68bc94dd2aabc7a33a4879c23165924563396c6d5991f5c702a12e184067d25cdb SHA512 bb259a25444029d8ea63577f0576ab283282298d27987e276bf4eb6d4ef00853ed019ad199830e9bb4e738f9a151feb55d53e76917508f1033c2b3ecd246276f
diff --git a/dev-python/cstruct/cstruct-5.3.ebuild b/dev-python/cstruct/cstruct-5.3.ebuild
new file mode 100644
index 000000000000..424b9e8357a9
--- /dev/null
+++ b/dev-python/cstruct/cstruct-5.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-cstruct-${PV}
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/python-cstruct/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest