summaryrefslogtreecommitdiff
path: root/dev-python/cvxopt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/cvxopt
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/cvxopt')
-rw-r--r--dev-python/cvxopt/Manifest4
-rw-r--r--dev-python/cvxopt/cvxopt-1.2.5.ebuild (renamed from dev-python/cvxopt/cvxopt-1.1.9.ebuild)26
2 files changed, 16 insertions, 14 deletions
diff --git a/dev-python/cvxopt/Manifest b/dev-python/cvxopt/Manifest
index b57ddf278a67..287aef723ba8 100644
--- a/dev-python/cvxopt/Manifest
+++ b/dev-python/cvxopt/Manifest
@@ -1,3 +1,3 @@
-DIST cvxopt-1.1.9.tar.gz 1872932 BLAKE2B 50990b8432d32db68580243a5f547a4be2fd36f23196b1505e90eccef9fab5526ea485bf9f81539842229eb276345edce12b064065a1e13125d5adca0de07e8c SHA512 bb0982cd1489157df4c7cd0dd92bf83b1692dc3a27d6b9a7a465dda9f9daea4ea5ef69e48642a879d036679bd0b0fe0dfd782433ce4cc570e90e11823733e58b
-EBUILD cvxopt-1.1.9.ebuild 2871 BLAKE2B 0dac227cc2abde1b4a493bbed7a52f51bcee1e7b6dc65cb289117d6fe42ea5a1e0c045343ebe2390413f9d62bba5211191094a6cdea713e366cbe5285b6f4b17 SHA512 befc873b5995e374565b9793b6b9077720ec667c961c6a0dd6160c2c3280131afcb2c1279b0cc7abd74f5bcb614a3c25486ce3f59a969157d89a99e47b2123a6
+DIST cvxopt-1.2.5.tar.gz 6742389 BLAKE2B 32e872d13624250610e7eecf2a5755b7b2adbf98dd9b7d1b0d6e236d62677fcdef7c08a2365d7b511f755a38b34a29ff78b280fb7e92ec6256a71c63e022e003 SHA512 d21d9977941140e76d1619a1239fab5d93a3467c4cbeacca2003168c96e1bbec9698563dba07107f6e0a84a0af92124d5c868af599bd049b64f47a3cd3753afc
+EBUILD cvxopt-1.2.5.ebuild 2963 BLAKE2B 449a65f303b77cb5c92e0819b49bfec7c828bcf46601a280dde0ec708c783fead5a05ee597a2579ef01660b41d51d75ab7bf34b0186e01a37042dcb98274c1eb SHA512 05433f0bffe2e55a9fb547f5a176886a10f4e8797dc292d1ad84bebf85153772df80c236f131fa3b38324760e5742c135d2e5ada4ddefcf5a53000bb4c93468d
MISC metadata.xml 805 BLAKE2B cfeb4a97635e28a1fe93b26897950dfe13268aef349647c5ca7455597e679ab7e79d21daf1b54f4c8855624abb8286676aff2da381782dd3b42b0a587f9396b2 SHA512 52bdd0bdc12807d7a3d2d820af3167b0768225167377bdf42e5f7218d5154deab2bee8bbcfdd173301e4b1d87f268bfb4bf6c1f884113c2d1f3fbf7fa1dc2ab6
diff --git a/dev-python/cvxopt/cvxopt-1.1.9.ebuild b/dev-python/cvxopt/cvxopt-1.2.5.ebuild
index 992320c342b4..4f197405a30a 100644
--- a/dev-python/cvxopt/cvxopt-1.1.9.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.2.5.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Python package for convex optimization"
-HOMEPAGE="http://cvxopt.org/"
+HOMEPAGE="http://cvxopt.org/ https://github.com/cvxopt/cvxopt"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc +dsdp examples fftw +glpk gsl"
+IUSE="doc +dsdp examples fftw +glpk gsl test"
+RESTRICT="!test? ( test )"
-RDEPEND="
+DEPEND="
virtual/blas
virtual/lapack
sci-libs/amd:0=
@@ -28,9 +29,12 @@ RDEPEND="
fftw? ( sci-libs/fftw:3.0= )
glpk? ( >=sci-mathematics/glpk-4.49:0= )
gsl? ( sci-libs/gsl:0= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( dev-python/sphinx )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )"
python_prepare_all() {
pkg_libs() {
@@ -93,11 +97,9 @@ python_test() {
python_install_all() {
use doc && HTML_DOCS=( doc/build/html/. )
- insinto /usr/share/doc/${PF}
distutils-r1_python_install_all
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
fi
}